"refresh" meta tag not working correctly

VERIFIED WORKSFORME

Status

()

Core
Networking
P3
normal
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: rusty.lynch, Assigned: Judson Valeski)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

(Reporter)

Description

18 years ago
If a page is visited using <meta http-equiv="refresh" content="10">,
then the page will reload as expected, but the browser will not 
really load a new page.

To see this create a simple CGI script that always returns the meta tag
but sends the current time in the body of the page.  Mozilla will 
keep reloading the page, bug the time will stay the same.  If you go
and then press the 'reload' button, a new page with an updated time is
displayed.
(Reporter)

Comment 1

18 years ago
nominating for nsbeta2
Keywords: nsbeta2

Comment 2

18 years ago
i experience this (linux) if i go to a page,leave then re-type the url to go
back to the page or use a bookmark.

i can produce it even easier w/ a basic html page that i update once i've left
the page and then come back to it via the url bar and/or bookmark.

Comment 3

18 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]
(Reporter)

Comment 4

18 years ago
The "refresh" meta tag bug ended up being a duplicate of bug #41269
which just got fixed. So, now the meta tag works as expected. 

The other part of this bug that was noticed by jae, is still broke.  Any attempt
at retyping the URL in the input field of the toolbar (or just pressing enter
when you are currently at the given URL) will result in the page being refreshed
but just from the cached copy.  This is a pain when using Mozilla, and
completely blocks using viewer effectively (since there is no 'reload' button.)

The problem is rooted in who ever is calling nsDocShell::LoadURI() with a
loadinfo object with refresh set to false. Without refresh set to true, the
URI will be loaded with the loadNormal flag, which will just pull the page 
from cache if it's there.

No longer blocks: 41273
No longer depends on: 41273

Comment 5

18 years ago
->valeski
Assignee: gagan → valeski
(Assignee)

Comment 6

18 years ago
sorry to do this, but please file a new bug. morphed bugs are bad.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 7

18 years ago
verified WFM
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.