Option --disable-xpinstall broken

RESOLVED INVALID

Status

RESOLVED INVALID
11 years ago
8 months ago

People

(Reporter: teaone, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: CVS 3.0a1pre (2008011714)

If option --disable-xpinstall given (I'm not sure if --disable-profilesharing affected too), the build process stop with error cannot find NSReg.h

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Can you please attach the end of your build log
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> Can you please attach the end of your build log
> 

Here it is.

uname -a
Linux sunny 2.6.23.9-85.fc8 #1 SMP Fri Dec 7 15:49:59 EST 2007 i686 i686 i386 GNU/Linux

.mozconfig
----------

. $topsrcdir/mail/config/mozconfig
mk_add_options MOZ_CO_PROJECT=mail
ac_add_options --disable-debug
ac_add_options --enable-optimize
ac_add_options --enable-static --disable-shared
ac_add_options --disable-libxul
ac_add_options --disable-tests
ac_add_options --disable-glibtest
ac_add_options --disable-libIDLtest
ac_add_options --enable-pango
ac_add_options --enable-xft
ac_add_options --disable-svg
ac_add_options --disable-svg-renderer
ac_add_options --disable-freetype2
ac_add_options --enable-default-toolkit=cairo-gtk2
ac_add_options --disable-glitz
ac_add_options --enable-canvas
ac_add_options --enable-official-branding
ac_add_options --disable-plugins
ac_add_options --disable-updater
ac_add_options --enable-plaintext-editor-only
ac_add_options --disable-pref-extensions
ac_add_options --disable-xpinstall
ac_add_options --disable-profilesharing

c++ -o nsComm4xProfile.o -c -I../../../../dist/include/system_wrappers -include ../../../../config/gcc_hidden.h -DMOZILLA_INTERNAL_API -DOSTYPE=\"Linux2.6.23.9-85\" -DOSARCH=Linux  -I../../../../dist/include/xpcom -I../../../../dist/include/string -I../../../../dist/include/intl -I../../../../dist/include/import -I../../../../dist/include/necko -I../../../../dist/include/msgbase -I../../../../dist/include/msgbaseutil -I../../../../dist/include/unicharutil -I../../../../dist/include/libreg -I../../../../dist/include   -I../../../../dist/include/impComm4xMail -I../../../../dist/include/nspr           -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-long-long -pedantic -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -Os -freorder-blocks -fno-reorder-functions   -DMOZILLA_CLIENT -include ../../../../mozilla-config.h -Wp,-MD,.deps/nsComm4xProfile.pp nsComm4xProfile.cpp
nsComm4xProfile.cpp:44:19: error: NSReg.h: No such file or directory
gmake[7]: *** [nsComm4xProfile.o] Error 1
gmake[7]: Leaving directory `/home/sun/Build/src/rpm/SOURCES/Mozilla/mozilla.org/mailnews/import/comm4x/src'
gmake[6]: *** [libs] Error 2
gmake[6]: Leaving directory `/home/sun/Build/src/rpm/SOURCES/Mozilla/mozilla.org/mailnews/import/comm4x'
gmake[5]: *** [libs] Error 2
gmake[5]: Leaving directory `/home/sun/Build/src/rpm/SOURCES/Mozilla/mozilla.org/mailnews/import'
gmake[4]: *** [libs] Error 2
gmake[4]: Leaving directory `/home/sun/Build/src/rpm/SOURCES/Mozilla/mozilla.org/mailnews'
gmake[3]: *** [libs_tier_app] Error 2
gmake[3]: Leaving directory `/home/sun/Build/src/rpm/SOURCES/Mozilla/mozilla.org'
gmake[2]: *** [tier_app] Error 2
gmake[2]: Leaving directory `/home/sun/Build/src/rpm/SOURCES/Mozilla/mozilla.org'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/home/sun/Build/src/rpm/SOURCES/Mozilla/mozilla.org'
make: *** [build] Error 2
The problem is that the import code requires the libreg module to be build, however disabling xpinstall and disabling xpcom obsolete components removes libreg from the build. This is done here:

http://mxr.mozilla.org/seamonkey/source/netwerk/build.mk#68
QA Contact: build → build-config
I believe this is a core bug, therefore moving to Core/Build Config. Firefox currently fails linking libxul with --disable-install set, however, I believe that if it could get to the browser/components/migration stage it would fail because of this bug as well.
Component: Build Config → Build Config
Product: Thunderbird → Core
QA Contact: build-config → build-config
--disable-xpinstall has been gone for a while.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.