Closed Bug 412737 Opened 12 years ago Closed 12 years ago

Dialog when accepting invitation lists read-only calendars

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mdelorme, Assigned: sebo.moz)

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Lightning 0.8 Pre build 2008011604

When I click on "Accept" when receiving an invitation as attachment 
a pop-up appears and list on subscribed calendars even those that are read only

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
all calendars are shown

Expected Results:  
only non read-only calendars should be shown
Flags: wanted-calendar0.8?
confirmed with Lt 2008012609
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows Vista → All
Flags: wanted-calendar0.8? → wanted-calendar0.8-
Attached patch patch (obsolete) — Splinter Review
The patch checks for writable status before offerering the chooseCalendar dialog.
Assignee: nobody → sebo.moz
Status: NEW → ASSIGNED
Attachment #300486 - Flags: review?(philipp)
Comment on attachment 300486 [details] [diff] [review]
patch

>+    var calendars = new Array();
>+    for each (cal in calArray) {
>+        if (!isCalendarWritable(cal)) {
>+            continue;
>+        }
>+        calendars.push(cal);
>+    }
Since you are not using count anywhere else, you can replace with {}. Also, you can shorten the foreach like so:

var calendars = calMgr.getCalendars({}).filter(isCalendarWritable);

r=philipp
Attachment #300486 - Flags: review?(philipp) → review+
Attached patch patch v2Splinter Review
patch as it should be checked in.
Attachment #300486 - Attachment is obsolete: true
Sebo, AFAIR you just got cvs access...?
(In reply to comment #5)
> Sebo, AFAIR you just got cvs access...?
> 
Yes, checked in on HEAD and MOZILLA_1_8_BRANCH.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.8
Thanks guys for your work, 
Keep going
Checked in latest nightly build 2008020719 -> task is fixed and verified.
Status: RESOLVED → VERIFIED
Component: Lightning Only → E-mail based Scheduling (iTIP/iMIP)
QA Contact: lightning → email-scheduling
Flags: wanted-calendar0.8-
You need to log in before you can comment on or make changes to this bug.