Cannot paste into a file upload field (input type=file)

RESOLVED DUPLICATE of bug 356071

Status

()

defect
RESOLVED DUPLICATE of bug 356071
12 years ago
12 years ago

People

(Reporter: bertramf, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9b2) Gecko/2007121016 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9b2) Gecko/2007121016 Firefox/3.0b2

I want to paste the location of a file to be uploaded into a web form, relevant code piece of it:

<table><tbody id=files>
  <tr><td><input type=file size=50 name=file1 class=hf_file>
</tbody></table>

But the middle mouse button here is simply ignored.


Reproducible: Always

Steps to Reproduce:
1. Mark any text using the mouse
2. Try to paste it using the middle mouse button into the field described in the details

Actual Results:  
Paste operation is ignored

Expected Results:  
The file location is put into the field.

This is a 32-bit firefox on a x64 Suse 10.3.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 356071
Why do you want to remove that field? Using the browse button and the File Upload dialog is so awkward (especially with the strange autocompletion that is in there currently).

I think, this dialog is a workaround for the missing paste functionality, not a solution.
You need to log in before you can comment on or make changes to this bug.