Changeing Location URL and pressing enter while still downloading a page causes an Assert

VERIFIED DUPLICATE of bug 26295

Status

()

P3
normal
VERIFIED DUPLICATE of bug 26295
19 years ago
16 years ago

People

(Reporter: jjs, Assigned: rpotts)

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
BuildID:    2000042708

If you start downloading www.cnn.com and change the URL location to 
www.mozillazine.org and press enter the following Assertion is raised (in debug)
0[b62ca0]: ###!!! ASSERTION: Channel list is not empty.: 'count == 0', file 
d:\mozilla\mozilla\netwerk\base\src\nsLoadGroup.cpp, line 238
(Stack trace and NSPR_LOG_FILE fragment below). Im not sure of the 
ramifications of this, will the left over channels close them selves 
correctly?. Also the URL change needs to occur before the page starts 
rendering, I have a feeling that its a problem if the URL change occurs before 
the other channels for the page are started.

Reproducible: Always
Steps to Reproduce:
1.Using a Debug build
2.Enter www.cnn.com in the Location bar and press enter
3.Wait for the location to change to http://www.cnn.com
4.Change the location to www.mozillazine.org and press enter before page 
rendering of cnn starts

Actual Results:  An assertion is shown stating that on canceling of the current 
channel group there were left over channels.

Expected Results:  No assertion should occur and www.mozillazine.org should 
show.

Stack trace and Log file didnt fit, appending
(Reporter)

Comment 1

19 years ago
Created attachment 9488 [details]
Stack Trace
(Reporter)

Comment 2

19 years ago
Created attachment 9489 [details]
NSPR_LOG_FILE fragment
(Reporter)

Comment 3

19 years ago
Opps, should have mentioned that this is a Dual CPU Win2K Machine. Will confirm 
on Single CPU when compilation completed.
OS: Windows NT → Windows 2000

Comment 4

19 years ago
I don't think the dual CPU is the problem here. I would let rpotts comment on 
that assertion. ->rpotts.
Assignee: gagan → rpotts
I see this if I load a slashdot.org forum page and try and load mozilla.org per 
the instructions. Single CPU W2K machine. 

Comment 6

19 years ago
confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true
I also have hit this assertion when going to a page with a redirect (see bug
46699).  This URL (http://209.1.224.17/hamlin483/) causes the assertion every
time I've tried.

Updated

18 years ago
Target Milestone: --- → Future
(Assignee)

Comment 8

18 years ago

*** This bug has been marked as a duplicate of 26295 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 9

16 years ago
VERIFIED/dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.