Implement doctype for XML documents

VERIFIED DUPLICATE of bug 15118

Status

()

Core
DOM
P3
normal
VERIFIED DUPLICATE of bug 15118
18 years ago
17 years ago

People

(Reporter: Heikki Toivonen (remove -bugzilla when emailing directly), Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-])

We already have it for HTML, so this is a "DOM Core parity issue".

I have been working on this for a little while already. doctype.name is trivial, 
because we can just about copy the code from HTML content sink.

Full implementation is trickier. I have experimented some, and have a somewhat 
working version that fills up name, publicId, systemId and internalSubset. I do 
not like the way I did it, though (in nsExpatTokenizer, not storing state 
although should). In any case, the nsExpatTokenizer is doing the wrong thing 
when it creates the doctype decl token: it creates a token with only the 
doctype.name part. This is partly Expat's fault: it reports doctype start with 
the doctype name, but all the other parts come as default tokens from Expat.

I am thinking it would perhaps be best to implement the bulk of this in the 
content sink (or perhaps DTD, have to take a look). I believe nsExpatTokenizer 
should also create a new doctype close token so the content sink (or whatever) 
knows when the doctype ended.
Trying to get some work for nsbeta2 ;)
Status: NEW → ASSIGNED
Keywords: nsbeta2

Comment 2

18 years ago
Marking nsbeta2+.  Heikki, we are currently in a push towards getting down to 
zero dogfood bugs.  Please do not check this in until after we've achieved that. 
 We will start accepting approved feature work after the zero dogfood bug 
milestone is hit and continue with that till June 22nd after which we'll go into 
the final six week stability push towards nsbeta2.  So, the time to check this 
in is after zero dogfood bugs and before June 22nd.

Hey, Johnny's visa came through.  Yours should be next, any time now! :-)
Whiteboard: [nsbeta2+]

Comment 3

18 years ago
It seems that I misunderstood the PDT process.  I don't have the authority to 
mark bugs nsbeta2+.  Removing the nsbeta2+ marker...  
Whiteboard: [nsbeta2+]

Comment 4

18 years ago
Putting on [nsbeta2-] radar.  Check via mozilla process.  See brendan/waterson.
Whiteboard: [nsbeta2-]
Hrmph, this is actually a duplicate....

*** This bug has been marked as a duplicate of 15118 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
Component: DOM Level 2 → DOM Other
Component: DOM Other → DOM Level 1
You need to log in before you can comment on or make changes to this bug.