Last Comment Bug 412965 - ARIA sliders and progressbars should not support ATK IText
: ARIA sliders and progressbars should not support ATK IText
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Aaron Leventhal
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-18 08:24 PST by Scott Haeger
Modified: 2008-01-25 05:50 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Expand on |if| block in nsHypertextAccessible::QueryInterface() (1.13 KB, patch)
2008-01-24 08:50 PST, Aaron Leventhal
surkov.alexander: review+
mbeltzner: approval1.9+
Details | Diff | Review

Description Scott Haeger 2008-01-18 08:24:35 PST
The ARIA progressbar seen here http://www.mozilla.org/access/dhtml/progressbar and the ARIA slider seen here http://www.mozilla.org/access/dhtml/simple-slider lead me think that sliders and progressbars should not support the Text interface.  An example of the text output from one of the objects is '|********-----------------|', which is of little value and complicates an AT's support of such an object.
Comment 1 alexander :surkov 2008-01-23 09:18:11 PST
Aaron, sounds correct?

I'm sure we create hypertext accessible for general nodes with aria role attribute. Possibly we should create generic accessible for some roles?
Comment 2 Aaron Leventhal 2008-01-24 08:50:02 PST
Created attachment 298956 [details] [diff] [review]
Expand on |if| block in nsHypertextAccessible::QueryInterface()

Alexander, I admit your approach sounds cleaner but it might have unintended consequences. So for now I'd like to just expand the list of nsHyperTextAccessible ARIA roles that don't support the text interfaces.
Comment 3 alexander :surkov 2008-01-24 09:19:24 PST
Comment on attachment 298956 [details] [diff] [review]
Expand on |if| block in nsHypertextAccessible::QueryInterface()

could you please put XXX comment to get back to this later?
Comment 4 Aaron Leventhal 2008-01-24 09:22:29 PST
Comment on attachment 298956 [details] [diff] [review]
Expand on |if| block in nsHypertextAccessible::QueryInterface()

Yes I will, thank you.
Comment 5 Mike Beltzner [:beltzner, not reading bugmail] 2008-01-24 13:08:39 PST
Comment on attachment 298956 [details] [diff] [review]
Expand on |if| block in nsHypertextAccessible::QueryInterface()

a=beltzner for 1.9

Note You need to log in before you can comment on or make changes to this bug.