input[type="text"] width problems when setting it in css.

VERIFIED DUPLICATE of bug 41306

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED DUPLICATE of bug 41306
18 years ago
18 years ago

People

(Reporter: James Lariviere, Assigned: Pierre Saslawsky)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
If I declare the width of an input[type="text"] in pixels versus percentages I 
get different renderings.

For example, if you have text inputs in a 1) table with width="800", 2) set a 
couple of text inputs with the width of 50%, and 3) a couple of inputs with a 
width set to 400px, rendering widths end up different.

All input text should render with the same widths.

If you look at the test case you'll see what I mean.

This is what I think the problem is.

If you declare the width of every table cell - text input is correct (for 
example: <td width="800">).

However, if you just declare it in the first cell and leave the following cells 
without a width (what normally occurs), the text inputs with widths defined as 
percentages nolonger render correctly while the text inputs with widths defined 
in pixels render fine.

I think that an <input> with a width defined in a percentage doesn't render 
correctly unless the table cell it is contained in has a width given in html.

My system is win98 build 2000053020
(Reporter)

Comment 1

18 years ago
Created attachment 9499 [details]
case showing how px and % widths renders differently in input[type="text"] form elements
This is really a very general and complicated issue regarding the inadequacies
of the CSS table model, and I'm probably going to file a bug explaining the
*whole* thing and mark this bug (and bug 40222) as duplicates of that bug...

Otherwise, things will be too confusing.
Marking as duplicate of rather general bug that explains the whole mess.

*** This bug has been marked as a duplicate of 41306 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
v. dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.