entering the site http://rokor1.pl.tl/ causes total freeze of the system

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
11 years ago
5 years ago

People

(Reporter: mw, Unassigned)

Tracking

({hang})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sg:dos] out of memory, URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.5; Linux 2.6.22.12-desktop-1mdv; X11; x86_64) KHTML/3.5.7 (like Gecko)
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.11) Gecko/20070914 Mandriva/2.0.0.11-1.1mdv2008.0 (2008.0) Firefox/2.0.0.11 as well as Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20070208 Mandriva/2.0.0.6-12mdv2008.0 (2008.0) Firefox/2.0.0.6

When trying to browse the site, Mozilla stops respomnding, the system is busy in 100% and heavy hdd operation. probably the only way out is hard reset. even ctrl+alt+bspce do not work. For both 32 and 64 bit version the effect is the same, while konqueror and opera work properly. The windows version of Mozilla doesn't crash on that site.

Reproducible: Always

Steps to Reproduce:
1. browse http://rokor1.pl.tl/
2.
3.
Actual Results:  
Mozilla doesn;t respond, system busy 100% and not responding, heavy hdd operation

Expected Results:  
show the site as other browsers do
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0 Branch

Comment 1

11 years ago
Created attachment 297954 [details]
Testcase (WARNING: hangs the entire desktop)

This is a standalone and somewhat reduced version of the URL.

Comment 2

11 years ago
Confirming bug, Firefox trunk 2008011804 on Linux.
When loading the testcase all memory is consumed and I see this on the console:
JavaScript error: file:///usr/local/test/413106-2.html, line 113: out of memory

-> JS Engine, for triage
Assignee: nobody → general
Status: UNCONFIRMED → NEW
Component: General → JavaScript Engine
Ever confirmed: true
Keywords: hang
Product: Firefox → Core
QA Contact: general → general
Whiteboard: [sg:dos] out of memory
Version: 2.0 Branch → Trunk

Comment 3

11 years ago
mw, do you have Kerio Personal Firewall ?

From <http://lucisandor.info/blog/?p=242> it looks like it is inserting the "popup" blocking code. I don't have a problem with the "blocking" script removed except for the numerous parsing errors for top and the fact that the animation is set to run every 1ms. Try disabling the popup blocking on the firewall since you don't need it with Firefox anyway. I look at the script more to find out the cause of the "hang".
Get a terrible hang on Windows XP.
Today http://rokor1.pl.tl/ didn't hang anymore, so I did a re-check for the regression range, this time with the testcase, but the range was correct.

Comment 7

5 years ago
Is this still an issue?
Seems to work fine now, please file a new bug if this is still a problem.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.