Forward button too small for its dropdown arrow

RESOLVED WORKSFORME

Status

()

Firefox
Theme
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Jakub 'Livio' Rusinek, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9b3pre) Gecko/2008011804 Fedora/8 (Moonshine) Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9b3pre) Gecko/2008011804 Fedora/8 (Moonshine) Minefield/3.0b3pre

I hovered my forward button and I saw little glitch.

Reproducible: Always

Actual Results:  
Button is probably too small.

Expected Results:  
Everything ok.
(Reporter)

Comment 1

10 years ago
Created attachment 297953 [details]
screenshot

Comment 2

10 years ago
Created attachment 298269 [details] [diff] [review]
adds right margin

I guess the dropdown image has never been centered when the toolbar button is hovered, but this is more visible now that bug 404825 has landed.

Because the "-moz-appearance: dualbutton" of the toolbarbutton uses no border, it is drawn on top of the dropmarker.

I tried to add a right-margin on the dropmarker. Apparently, the required margin size is engine dependent. 2px is fine with Clearlooks while 3px better suits Human (I'll attach a screenshot).

Comment 3

10 years ago
Created attachment 298270 [details]
screenshot with several right-margin values and themes

From top to bottom:
Clearlooks with right-margin: 0px (actual value)
Clearlooks with right-margin: 2px
Clearlooks with right-margin: 3px
Human with right-margin: 0px (actual value)
Human with right-margin: 2px
Human with right-margin: 3px

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk

Updated

10 years ago
Attachment #298269 - Flags: review?(rflint)
(Reporter)

Comment 4

10 years ago
It should be detected somehow...
Component: OS Integration → Theme
QA Contact: os.integration → theme
Summary: forward button too small for it's dropdown arrow → Forward button too small for its dropdown arrow
Will bug 415161 take care of this?
(Reporter)

Comment 6

10 years ago
This bug is now INVALID, since forward's dropdown is now merged with back's dropdown.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 7

10 years ago
Sorry, it's WORKSFORME.
Resolution: INVALID → WORKSFORME

Updated

10 years ago
Attachment #298269 - Flags: review?(rflint) → review?
Comment on attachment 298269 [details] [diff] [review]
adds right margin

Unset the request if you don't want review. Don't leave it dangling.
Attachment #298269 - Flags: review?
You need to log in before you can comment on or make changes to this bug.