Password Manager forgetting old sites when new passwords added

RESOLVED DUPLICATE of bug 379997

Status

()

Toolkit
Password Manager
--
critical
RESOLVED DUPLICATE of bug 379997
11 years ago
10 years ago

People

(Reporter: Robert A. Rosenberg, Unassigned)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

I use a number of sites that use cPanel and the HTTP Password option (which triggers an Authentication Required password screen). I just tried to access a few of these sites and discovered that if I have 2 separate sites defined, an attempt to access a third and add its credentials to the manager will delete one of the prior entries. I have not attempted to delete some normal passwords to see if this is an issue of being only allowed to have two of these types of entries or if I have hit some limit on the size of the file used to store the passwords. It is the 2nd entry that gets replaced when this occurs (at least 2 2nd in alpha sequence since the sites that flip-flop sort after the one that stays).

Reproducible: Always

Steps to Reproduce:
1.
2.
3.


Expected Results:  
I should be able to store as many cPanel passwords as I have sites.

Updated

11 years ago
Severity: major → critical
Keywords: dataloss
What's the hostname and HTTP realm of the logins being saved? Do you see the entries in signons2.txt (in your profile) or in Preferences -> Security -> Show Passwords?
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> What's the hostname and HTTP realm of the logins being saved? Do you see the
> entries in signons2.txt (in your profile) or in Preferences -> Security -> Show
> Passwords?
> 

I apologize for the delay in responding but here are your answers. The cPanel entry appears in both signons2.txt and the Preferences -> Security -> Show
Passwords entry but can vanish and need to be recreated. I did some more testing and I have found the trigger (I was wrong about it being a lack of space issue). What seems to be the actual cause is logging out of cPanel as opposed to staying logged in but navigating away. So long as I just navigate away, when I return (after quitting and restarting FF) I get the Logon Menu but it is filled in (since the entries are still in the signons2.txt file). Logging off cPanel IMMEDIATELY removes the entry (going to the Show Passwords menu right after the cPanel logout shows the entry no longer there). I do not know if this is the correct action or not but it is a 100% sure way of seeing the entry deletion.
Looks like cPanel uses HTTP authentication (WWW-Authenticate header), so this is almost certainly another instance of bug 379997. (Presumably the log-out is sending a 401, our netwerk code thinks the stored login is bad, and so it's deleted.)

This issue is fixed in Firefox 3, try a beta if you'd like.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 379997
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.