Navigating with keyboard prevents cursor from changing when hovering over links

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: FirasE, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-07-30])

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008011904 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008011904 Minefield/3.0b3pre

If you navigate to a page via the keyboard (backspace key, alt-arrow, etc) and you scroll the new page up or down with the keyboard to position the cursor over a link, the cursor will not change into a hand. Still on the same page, if you move the mouse to position the cursor over a link, it will properly turn into a hand.

Reproducible: Always

Steps to Reproduce:
1. Go to a page full of links http://www.google.com/search?q=stuff
2. Click one of the links on the page
3. Position the cursor with the mouse so that it will be in the same vertical position as links on the previous page
4. Don't touch the mouse now, and hit backspace or alt-leftarrow
5. Now hit the up/down arrow keys so the cursor hovers over links
Actual Results:  
The cursor does not change into a hand

Expected Results:  
The cursor should change into a hand
I see this also in Firefox 1.x so this is not a (recent) regression.

Comment 2

9 years ago
Related to/duplicate of Core bug 269415?
Does this still happen in Firefox 3.6.6 or later in a fresh profile?
Whiteboard: [CLOSEME 2010-07-30]
Version: unspecified → 3.0 Branch
(Reporter)

Comment 4

8 years ago
works fine now
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.