https URIs don't work until restart after logging into T-Mobile internet

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: samuel.sidler+old, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Details

(Whiteboard: [CLOSEME - 6/1])

Since I switched to Camino 1.6b2, I noticed that I no longer have to restart Camino to get https URIs to work. When I was using trunk, I did. Plus, it'd hang on quit to get those https URIs. Here's the process I followed:

1. Open a bunch of URIs (https ones too) in Camino at home
2. Put my machine to sleep
3. Go to Starbucks
4. Wake up my computer
5. Open Safari and login to T-Mobile internet (I've always done this so as not
   to scare Camino or something; i.e., no good reason).
6. Go to Camino and refresh an https URI like Bugzilla.
7. The URI never loads
8. Quit Camino
9. HANG
10. Force quit
11. Open Camino
12. https works again!

This process never fails on branch. Camino always has https URIs working fine and doesn't hang on quit.

I'm sure this has nothing to do, directly, with T-Mobile internet, that's just where I've noticed it. Likewise, this probably isn't a Camino bug, but something in core, but I'm filing here because I haven't checked it in Minefield yet to know if it does the same thing. Smokey mentioned something about NSPR logs I could get when this happens. Of course, I'd have to use trunk again too...

I'll test more later.

It probably has something to do with the overly corporate attitude of Starbucks, but meh. ;)

Comment 1

11 years ago
I wonder if this *is* something specific to T-Mo's Hotspot service, because I don't think I've ever seen this problem at the various airports I've used non-free (login-required) Internet, and I've pretty much exclusively used trunk since about three weeks after we shipped 1.5.

Comment 2

11 years ago
Sam, have you ever done any more digging on this to see what the root cause might be? Specifically, did you ever test in Minefield to see if it's a Core bug?
Sam, have you not been frequenting Starbucks or the trunk? ;)
Whiteboard: [CLOSEME - 6/1]
Closing this; Sam, if you're ever in a position to test this again and it still happens, please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.