Firefox fails to launch from shortcuts

RESOLVED WORKSFORME

Status

()

Toolkit
Startup and Profile System
--
major
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Gary, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

When launching Firefox by double-clicking on a URL shortcut from the Windows Desktop, only the first shortcut works. All subsequent shortcuts fail to open.

Reproducible: Always

Steps to Reproduce:
1. Firefox is set as the default browser. 
2. Create two shortcuts on Windows Desktop (e.g. one for http://www.google.com and one for http://www.mozilla.com).
3. Make sure all instances of Firefox are closed.
4. Double-click on one of the shortcuts from the Windows Desktop (Firefox launches and displays the page).
5. Double-click on the second shortcut (nothing happens - no new tab and/or browser is opened).

Actual Results:  
Only the first shortcut opens in Firefox.

Expected Results:  
Each shortcut should open in a new tab.

I was still able to reproduce this after completely uninstalling Firefox 2.0.0.11 (including deleting the entire Mozilla directory under "Application Data", and reinstalled it with no additional plugins.
If I make IE7 the default browser and try the same thing it works fine with IE7.
(Reporter)

Updated

10 years ago
Summary: URL Shortcuts don't launch browser. → Firefox fails to launch from shortcuts
(Reporter)

Comment 1

10 years ago
This is very annoying because many of the items under the Windows Start menu are often links to web pages. If Firefox is already running, then clicking on any of these links does absolutely nothing.
Works for me with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
(Reporter)

Comment 3

10 years ago
I just tried to confirm this on another PC with Windows XP and it works fine! 
Any suggestions on how to get this to work on my home pc? As I mentioned I uninstalled Firefox and deleted the Mozilla directory under "Application Data". I then reinstalled Firefox with no additional plugins. The problem still occurs, but works fine if I make IE7 the default browser. Can someone please help?
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit

Comment 5

10 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

please comment if you still see problem using current version
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

10 years ago
It is working now with Firefox 3.0.3
I believe the problem in 2.0.0.11 was caused by the Google toolbar available at that time.
You need to log in before you can comment on or make changes to this bug.