Collapsing folder in bookmarks sidebar causes bookmark under mouse to be selected

VERIFIED DUPLICATE of bug 406269

Status

()

VERIFIED DUPLICATE of bug 406269
11 years ago
9 years ago

People

(Reporter: abillings, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
If a user has the bookmarks sidebar open with a folder open in it as well, if they click on the folder icon to close the folder, the folder will close *and* the bookmark now under the mouse pointer after closing will be selected (following the closing and change of bookmark scrolling).

Steps to Reproduce
1. Have enough bookmarks in your menu to cause quite a bit of vertical scrolling. Have a folder in this bookmark (like "Unfiled Bookmarks") full of items.
2. Open the folder, causes its contents to appear and the bookmarks to scroll upwards to make room for the folder contents.
3. Close the folder by clicking on it.

Result: When the folder collapses and the display shifts (due to change in vertical spacing caused by folder closing), whatever bookmark winds up under the mouse selection will be selected even though you only clicked once, on the folder, to close the folder.

This was seen in Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b3pre) Gecko/2008011904 Minefield/3.0b3pre but it has been around for at least a few days before I thought about it.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 406269
(Reporter)

Comment 2

11 years ago
Doh. I searched too. Ah well.
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.