[gnomestripe] folders on bookmarks toolbar are missing icons

RESOLVED FIXED in Firefox 3 beta3

Status

()

RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: dbaron, Assigned: ventnor.bugzilla)

Tracking

Trunk
Firefox 3 beta3
x86
Linux
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Bug 404825 intentionally (after some debate, it seems) removed the folder icons from the bookmarks toolbar in Gnomestripe.  This causes a mix of icons and folders in the bookmarks toolbar to appear quite odd: the name of the folder runs in to the name of the icon for the previous item.  (The change introducing the dropdown arrows seems good to me, though.)

Steps to reproduce: Add some bookmarks and some folders to the bookmarks toolbar

Expected results: Visual appearance clearly distinguishing items, perhaps with additional user interface to indicate that more is available by clicking the folders.

Actual results: Folder preceded by non-folder is visually indistinct, and there is in general less clear a feeling that the toolbar contains a set of items.
Flags: blocking-firefox3?
Created attachment 298203 [details]
screenshot before bug (Linux nightly 2008-01-16-04-trunk)
Created attachment 298204 [details]
screenshot with bug (Linux nightly 2008-01-17-04-trunk)
(In reply to comment #0)
> runs in to the name of the icon for the previous item.  (The change introducing
> the dropdown arrows seems good to me, though.)

Except that there is now no visual continuity in the gnomestripe theme.  Why do these dropdown markers look completely different that the ones for the forward and back buttons?
BTW.  userChrome.css code to revert this is:

.bookmark-item[container] > .toolbarbutton-menu-dropmarker {
  display: none !important;
}

.bookmark-item[container] > .toolbarbutton-icon {
  display: -moz-box !important;
}
Or, you could install my new Gnomestripe Folder Icons extension from http://www.wg9s.com/mozilla/firefox/extensions .
Ventnor: is there any reason you removed this? Linux parity? It's a pretty big change, and I'm not sure for the better in this case, since those things *are* bookmark folders.
I still like the change but feedback (bugzilla, irc, mozillazine forums) has generally been very negative, so it's probably the best to change it back before beta 3 if possible.

Comment 8

11 years ago
I think the folder and RSS icons should be restored. Linux is not Mac.
Jakub, that's strange to hear from you. I thought all you cared about was platform look and feel? The way it currently is is as native as it can be. ;)

Still, I agree that we should change back. Mostly because of livemarks (two different kinds of containers is something special in firefox) because I doubt anyone had considered this case.
(Assignee)

Comment 10

11 years ago
Created attachment 300127 [details] [diff] [review]
Change back

Bring back icons, but keep the dropdown arrow.
Assignee: nobody → ventnor.bugzilla
Status: NEW → ASSIGNED
Attachment #300127 - Flags: review?(rflint)
Attachment #300127 - Flags: review?(rflint) → review+
(Assignee)

Comment 11

11 years ago
Comment on attachment 300127 [details] [diff] [review]
Change back

Really wanted for beta 3 since we're leaning back to use of icons rather than over-simplification.
Attachment #300127 - Flags: approval1.9?
Comment on attachment 300127 [details] [diff] [review]
Change back

a=beltzner
Attachment #300127 - Flags: approval1.9? → approval1.9+
(Assignee)

Updated

11 years ago
Keywords: checkin-needed
Thanks Michael, I appreciate that restore :) .
mozilla/browser/themes/gnomestripe/browser/browser.css 	1.161 
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 beta3
(Assignee)

Updated

11 years ago
Duplicate of this bug: 414151

Comment 16

11 years ago
(In reply to comment #10)
> Created an attachment (id=300127) [details]
> Change back
> 
> Bring back icons, but keep the dropdown arrow.
> 

Well I'm not talking about "clutter" but the icon+arrow combo takes quite a lot of real estate in the bar. I thought the folder icon was intuitive enough to every Linux users as to what happens when they're clicked..

Updated

11 years ago
Flags: blocking-firefox3? → blocking-firefox3+
You need to log in before you can comment on or make changes to this bug.