Match case does not work correctly in find

RESOLVED WORKSFORME

Status

()

Toolkit
Find Toolbar
--
minor
RESOLVED WORKSFORME
10 years ago
a year ago

People

(Reporter: Sjoerd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2

When highlighting all found search items and subsequently pressing "Match case", the items which case does not match are still highlighted.

Reproducible: Always

Steps to Reproduce:
1. Search for something.
2. Enable "Match case".
Actual Results:  
Items which case does not match are still highlighted.

Expected Results:  
Upon pressing the button, only the items which match should be highlighted.
This works for me with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008012008 Minefield/3.0b3pre
Component: Search → Find Toolbar / FastFind
QA Contact: search → fast.find
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
Confirmed on a Mac. Something very fishy is going on with the "Match Case" option, and I don't think it's directly related to the "Highlight All" option.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

9 years ago
I find that in some pages Match Case is simply not working at all, never mind showing some kind of delay. This is not only when clicking Highlight All. In the same application session that I'm in right now, in one window that has numerous tabs open I am searching for the string "Ning" with the Match case box checked and every instance of "ning" is being found when I click Next, including word containing ning such as "learning".

Same browser session, new window, I went to nytimes.com and did a match-case find for "The". In that window the search works properly, finding only initial-cap strings.

I wonder whether this might be some kind of extension conflict, but I cannot quit my browser session right now to restart in safe mode (and I sure wish someone would make it easier to do so on Mac, but that's another issue I suppose).

I'll post again if I nail anything down but meanwhile the word "instantly" should come off the end of the bug summary, and I suspect platform might be "All" since I'm on a Mac.
Summary: Match case does not work instantly → Match case does not work correctly in find

Comment 4

7 years ago
This appears to be fixed on my Mac, as of the last several versions of FF. Can others confirm? I'm now in Intel 10.5, was on PPC 10.4 when I entered the agove comment.
Based on comment 1, comment 4, my own testing on Mac OS X 10.6, and the age of this bug, I think this got fixed somewhere along the way.

I'm marking it as RESOLVED WORKSFORME. Sjoerd, if you can still reproduce this, feel free to reopen it.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Comment 6

a year ago
I'm having this problem on Windows 10
You need to log in before you can comment on or make changes to this bug.