Move live bookmark link to top instead of bottom of rss links.

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED WONTFIX
11 years ago
6 years ago

People

(Reporter: Joshua Dimmack, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b2) Gecko/2007121014 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b2) Gecko/2007121014 Firefox/3.0b2

It would be nice if the link to the main page in live bookmarks were moved to the top of the rss list instead of the bottom. scrolling over a large list of rss titles is a lot more inconvenient than mousing over the site link to get to the first feed update. I think seeing the updates and having access to the site link at the top are more important than having the newest feed item at the top.

Reproducible: Always

Steps to Reproduce:
1.Create a live bookmark from an rss feed on the bookmarks toolbar.
2.Try to use the live bookmark to go to the main page.
3.Scroll through a potentially long list of RSS items before reaching the link.
Actual Results:  
I have to do a lot of scrolling to load the rss main page.

Expected Results:  
Being able to more quickly get to the rss main page by either moving the link to the main page from the bottom of the feed items or make it so I can double click the live bookmark to use it as a regular bookmark.
Component: Bookmarks → Places
OS: Mac OS X → All
QA Contact: bookmarks → places
Hardware: Macintosh → All
Version: unspecified → Trunk
I agree, I find the current position of the main site link very uncomfortable.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I don't think this is a common action for most live bookmarks use-cases.  If you're going to the site instead, just bookmark the site...
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

10 years ago
So you think we should have a bookmark right next to our live bookmark to the same site on our bookmarks bar just because you don't want to move a link to make the live bookmarks more functional?
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
If you are clicking the homepage link often enough that its worth the extra movement on every click of a livemark button, yes, I would recommend that.

Don't reopen this bug unless you have some new argument.  (please also read https://bugzilla.mozilla.org/page.cgi?id=etiquette.html for some guidelines about reopening bugs...)
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 5

10 years ago
Ok my new argument is that the function is already implemented into the system, but in a less than optimal way. How would adding a double click to go to the main page affect the current users?
Dimmack, please don't be angry.

I must say changing double click is not recommended, because the common behaviour of bookmark folders is that if they are double-clicked, all bookmarks inside them are opened in tabs. Live bookmarks are a sort of "folder of bookmarked feeds". Anyway:

@Mike Connor: I think at that point Firefox can also remove completely home page link, because in that position is completely useless.
What I do normally is to see if there are new feeds. If it is so, I go to the homepage. I don't open feed-by-feed. In this way on the contrary I must open a feed link, and from that page go to the home page of the site. Quite annoying. This is the reason why now I use Google Reader.
Keywords: polish, ue, uiwanted
Yes, its not optimal for this particular case.  But its almost certainly a secondary action in any sane design, as the point is to see the RSS entries, not the homepage.

Lucas, your use-case is rather odd, I don't know why you'd look at the entries and then go to the home page instead of the entries that you're interested in... oh well.

Anyway, this is still WONTFIX.
Keywords: polish, ue, uiwanted
(In reply to comment #7)
> I don't know why you'd look at the entries and then go to the home page instead > of the entries that you're interested in

Because if I'm interested in more news, I can read them all in one page (especially true for Blogs). Why must I open page-by-page? :-)
(Reporter)

Comment 9

10 years ago
(In reply to comment #8)
> (In reply to comment #7)
> > I don't know why you'd look at the entries and then go to the home page instead > of the entries that you're interested in
> 
> Because if I'm interested in more news, I can read them all in one page
> (especially true for Blogs). Why must I open page-by-page? :-)
> 

I use the feature exactly the same way. I click on the live bookmark, read the subjects of new entries, if anything is worth reading I go to the main page to see all the stories. Going to the main page also has the added benefit of showing the feed in context of the main page with log in fields and other features of the page which I may wish to access as a result of news.

Perhaps another solution would be to limit the number of feed items that show up when one clicks on a live bookmark from the bookmark bar. I have a feed that shows entries #70-147 that must be scrolled through to access the home page link, which is an established feature of the live bookmark. I think having two bookmarks to the same site is a very sloppy hack fix when the live bookmark is supposed to be able to load the main page (it does but scrolling through over 70 feeds is so inefficient that it practically makes the feature useless).
 As I stated originally I think that users who don't use the homepage link of a live bookmark would be much less inconvenienced skipping one line of 'go to homepage' (and in fact may actually start using said feature as a result of it being more functional) than anyone trying to scroll through a (from what I can tell) potentially unlimited number of feeds. Bear in mind that is is included in the browser and I subject that anything included in the browser by design should be usable and not 'not fixed' because it is 'not a common action for most use cases'. If its in the browser it should be realistically usable.
(Reporter)

Comment 10

10 years ago
Another way of looking at this.

In the bookmarks menu all of the browser features [bookmark this page etc.]are at the top of the menu and the user added bookmarks are at the bottom. Browser features > User added content. We don't want bookmarks that we are adding to push browser commands out of the way. That's exactly what the live bookmark is doing. Its putting 'user added (by subscribing to the feed) bookmarks' over a browser command in the pull down menu for the live bookmark on the toolbar. Its not consistent and it doesn't make sense to put user bookmarks over browser functions. Imagine the bookmarks menu with the bookmarks folder at the top. 
(Reporter)

Comment 11

10 years ago
One last possible fix. In the right click pull down the open all in tabs option is at the top but the open homepage option isn't. Could the open homepage option be added to the right click pull down menu? Preferably up at the top with the open all in tabs command?
I think it's a good idea. I opened another bug: Bug 441013
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks

Comment 14

6 years ago
Okay, so this has apparently happened in v13.  Can't find a more-recent bug about it.  Do not want.  Is there an option in about:config to change it back?

Comment 15

6 years ago
(In reply to mpd from comment #14)
> Okay, so this has apparently happened in v13.  Can't find a more-recent bug
> about it.  Do not want.  Is there an option in about:config to change it
> back?

I also would have preferred that this not be changed, since I never use the homepage link (on the rare occasion I want to visit the homepage, I can get there from the most recent article).

The following code in my userChrome.css file makes the home page link and the separator after it go away entirely. It's possible that someone with stronger CSS skills could do some positioning magic to make them go back to the bottom, but I just don't care that much :)

/*
 * Get rid of the "Open [home page]" link at the top of an RSS feed.
 */
menuitem.openlivemarksite-menuitem,
menuitem.openlivemarksite-menuitem + menuseparator
{
    display: none !important;
}
You need to log in before you can comment on or make changes to this bug.