Closed Bug 413507 Opened 12 years ago Closed 12 years ago

These live bookmarks work in Firefox 2 but not in trunk

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 381357

People

(Reporter: bugzilla, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008012204 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008012204 Minefield/3.0b3pre

These feeds are properly expanded as Live Bookmarks in both the Bookmarks menu and Bookmarks sidebar in Firefox 2 but not in trunk.
http://www.intelligententerprise.com/blog/movabletype/index.xml
http://www.xitimonitor.com/rss/xtmflux2_EN.xml
http://www.desktoplinux.com/backend/headlines.rss

Instead of feed items it displays: "Live bookmark feed failed to load"

Reproducible: Always

Steps to Reproduce:
1. Add any of the listed feeds as a live bookmark.
2. Try to expand the live bookmarks in the bookmarks menu or the sidebar menu.

Actual Results:  
No feed items are displayed. Instead error message: Live bookmark feed failed to load is shown.

Expected Results:  
Feed items are displayed

According to W3C validator, they are OK but are being served with an incorrect MIME type: text/plain or text/HTML
http://validator.w3.org/feed/check.cgi?url=http%253A%252F%252Fwww.intelligententerprise.com%252Fblog%252Fmovabletype%252Findex.xml
http://validator.w3.org/feed/check.cgi?url=http%253A%252F%252Fwww.desktoplinux.com%252Fbackend%252Fheadlines.rss
http://validator.w3.org/feed/check.cgi?url=http%253A%252F%252Fwww.xitimonitor.com%252Frss%252Fxtmflux2_EN.xml

Is teh trunk more strict that Firefox 2 for MIME types?
Not intentionally.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 381357
You need to log in before you can comment on or make changes to this bug.