Closed Bug 413565 Opened 14 years ago Closed 14 years ago

free list construction ignores free things

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: igor, Assigned: igor)

References

Details

Attachments

(2 files)

The free list construction code in js_GC adds to the free list only things that were just freed. It skips the already free cells. This is a consequence of my patch for bug 333236.
Flags: blocking1.9?
Attached patch v1Splinter Review
Attachment #298570 - Flags: review?
Comment on attachment 298570 [details] [diff] [review]
v1

I must be smoking something when wrote that code.
Attachment #298570 - Flags: review? → review?(brendan)
Attached patch diff -b of v1Splinter Review
I must have been inhaling while reviewing, then...

/be
Flags: blocking1.9? → blocking1.9+
Attachment #298570 - Flags: review?(brendan)
Attachment #298570 - Flags: review+
Attachment #298570 - Flags: approval1.9+
This bug should be partly responsible for the regression in Sun Spider benchmarks.. According to the bug 408144 comment 5 and 6, there here is an extra regression that happens around 2007-09-19, the day when I landed the patch.
Blocks: 408144
Status: NEW → ASSIGNED
I checked in the patch from comment 1 to the trunk: 

http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&branch=HEAD&cvsroot=%252Fcvsroot&date=explicit&mindate=1201093262&maxdate=1201093534&who=igor%25mir2.org
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Flags: in-testsuite-
Flags: in-litmus-
About regression test for this:

in principle it should be possible to has a test case for this. Since the result of this bug is waste of unused GC cells in the allocated arenas, it should be possible to create a code that without the bug fixed would require to allocate, say, 4GB of memory, when in reality it needs just 8 MB.
Flags: in-testsuite- → in-testsuite?
You need to log in before you can comment on or make changes to this bug.