If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

text gets deleted in Composer

VERIFIED FIXED in M16

Status

()

Core
Editor
P3
critical
VERIFIED FIXED
18 years ago
16 years ago

People

(Reporter: rubydoo123, Assigned: Joe Francis)

Tracking

Trunk
All
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+]{M16 Blocker] fix in hand)

(Reporter)

Description

18 years ago
using build from 6/2 on win98, the text in the Composer window just disappears 
from the BODY element start tag to the BODY element end tag all the way through. 
I think it has to do with the backspace. I am sure there will be numerous ways 
to repro this -- this just happens to be how I found it.

1. enter text:
kjsfhdslf
dljdf lskdfj ds
dlfkjdskfjds
ldsjflsdkfjksd sdfkjsd
ldksfjds 

2. on 1st line - enter h3
3. on 3rd line - seelct some text and make it B, select some more text and make 
it I
4. on 4th line - select some text and make it U
5. on 2nd line - make it a P
6. on 5th line -- set focus in the center, hit return, enter 2 lines of text,
7. hit 3 returns, and enter a line of text, 
8. hit 3 returns, enter 2-3 lines of text, 
9. hit 3 returns, enter text, 
10. Now -- here comes the good part -- delete the text you entered last by using 
the backspace key, do not use any other keys or move the caret, continue to hit 
the backspace key to delete the last 3 returns, continue to backspace to delete 
the next few lines of text, continue to backspace to begin deleting the next 
section of returns -- and boom, the text just goes 'bye-bye' -- can't recover 
the text with undo either. Major bummer if you have lots of unsaved text in your 
file

sounds convoluted, but this is how I can get it to delete the text consistently. 
There is nothing in the console, no errors, nothing. I saved it once just to see 
what was left -- and only the head and its children are there.

After the text is deleted, I can no longer toggle between modes either, nor can 
I enter text.
(Reporter)

Comment 1

18 years ago
nominate for dogfood
Keywords: dogfood
Target Milestone: --- → M16

Comment 2

18 years ago
I see this too.  It's happened to me two or three times today while eating mail
dogfood -- I agree this is a dogfood bug, data loss and very frustrating when it
happens.  Undo doesn't make the text come back, and I can't get focus back in
the window or type anything further.
(Reporter)

Comment 3

18 years ago
*** Bug 41424 has been marked as a duplicate of this bug. ***

Comment 4

18 years ago
Putting on [dogfood+] radar.
Whiteboard: [dogfood+]
(Assignee)

Comment 5

18 years ago
accepting
Status: NEW → ASSIGNED
(Assignee)

Comment 6

18 years ago
i'm working on this... I've also seen crashes during deletion as well.  stay 
tuned.
(Reporter)

Updated

18 years ago
Blocks: 41812
(Reporter)

Comment 7

18 years ago
*** Bug 41884 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 8

18 years ago
in last nights build 2000060720, I can't reproduce this anymore, I'm not sure 
what got checked in that fixed this, but it is now working fine. Asking Sujay to 
try it out too.
(Reporter)

Comment 9

18 years ago
well, in today's build I can reproduce the problem -- bummer
(Reporter)

Comment 10

18 years ago
the bad news -- it still happens, the good news (sort of) is I can reproduce 
this which a much simpler test case. Try this: Note: (R)-- is the enter/return 
key and <- is for left arrow key

Type in
a(R)
b(R)
c(R)
(R)
(R)
(R)
abc

Then <- left arrow to the left of a, in the last line you just typed, now use 
your backspace key -- boom -- all of text gets deleted
(Reporter)

Comment 11

18 years ago
*** Bug 41886 has been marked as a duplicate of this bug. ***

Comment 12

18 years ago
This bug is absolutely killing me. I'm losing a ton of data composing mail
messages. Any ETA? If reproducing is difficult, my steps in bug 41424 are pretty
simple.
(Assignee)

Comment 13

18 years ago
Phil, I'm hoping to finish this off tonight.
Whiteboard: [dogfood+] → [dogfood+] ETA 6/9/00

Comment 14

18 years ago
Woohoo! Thanks Joe!

Comment 15

18 years ago
Could we get this on the M16 branch too?
Whiteboard: [dogfood+] ETA 6/9/00 → [dogfood+]{M16 Blocker] ETA 6/9/00
(Assignee)

Comment 16

18 years ago
what a difference a day makes.  i was on totally the wrong scent thursday.  i do 
have a fix now, though, and approval.  I'll check in once reviewed and tree goes 
green.  Apologies for the delay.
Whiteboard: [dogfood+]{M16 Blocker] ETA 6/9/00 → [dogfood+]{M16 Blocker] fix in hand
(Assignee)

Comment 17

18 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 18

18 years ago
test case in 41886 is still reproducible on *LINUX*. It seems that
the contents aren't refreshed on LINUX platform.

(Assignee)

Comment 19

18 years ago
41886 is not a dup.  I've commented there.

Comment 20

18 years ago
This is not fixeed on today's m16 builds (2000061201M16) on all 
platforms.Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 21

18 years ago
huh?  it works for me.  You tried it on mac/win/unix, and it was broken on all 
three?  Which test case did you try?
(Reporter)

Comment 22

18 years ago
Joe, following the initial steps I put in, I can dup this on win98 commercial 
build. Maybe there is some difference between your debug build and the comm 
build. In fact, I was able to lose data (makes it sound like a good thing 
doesn't it?) when I backspaced over the first return.
(Reporter)

Comment 23

18 years ago
ok, this is what happened -- the fix got checked into the M17 trunk but not the 
m16 branch. This works great in M17 build from this afternoon (6/12 5:17)
(Assignee)

Comment 24

18 years ago
I've confirmed on all three platforms that this bug is fixed.  It didn't go into 
the M16 branch until early this morning, so you may need to wait until tonight to 
see it in M16 builds.  It's been in the tip since Friday night.

Marking fixed.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 25

18 years ago
verified in 6/13 M16 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.