Font gets change when paragraph numbering starts

RESOLVED DUPLICATE of bug 250539

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 250539
10 years ago
6 years ago

People

(Reporter: Peter Ashford, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: version 2.0.0.9 (20071031)

My default font is Comic Sans MS.  No problem until I start a bulleted or numbered list or an indented section then the font switches to Variable Width!  I then have to complete the text, select All and select the initial default font again 

Reproducible: Always

Steps to Reproduce:
1. As above
2.
3.
Actual Results:  
As above

Expected Results:  
The current font should not change of its own accord.

Comment 1

9 years ago
No, the default is always shown as "Variable Width".  If it says "Comic Sans MS" then it is just a font tag, not the default.  Set the real default in the Fonts & Encodings dialog (Tools - Options - Display - Formatting - Fonts...)

In a new list item or a blockquote, you get the default.  If you want a font tag in there, specify a named font.

The confusion arises because it is not obvious that "Variable Width" really means "default".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 159249
(Reporter)

Comment 2

9 years ago
This will not work if you use Comic Sans MS as your chosen font!

In (Tools - Options - Display - Formatting - Fonts...)  Comic Sans MS is not one of the many fonts available as it is when selecting a font during email writing !
Resolution: DUPLICATE → WONTFIX

Updated

9 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Comment 3

9 years ago
This seems to be the same issue as reported here: https://bugzilla.mozilla.org/show_bug.cgi?id=435400

Comment 4

9 years ago
This particular defect has annoyed me as well.  I will add what detail I can to help this defect be reproduced:

Reproducible: Always

Steps to Reproduce:
1. In Composition->General->HTML, select a font other than the default font
2. Open a new email
3. Type in some text, on a new line create a numbered list, and enter more text after the numbered list.

Actual Results:
The default font that is selected in the options is no longer used after the numbered list is started.  Instead, "Variable Width" is used from the point that the list is started.  If you select the entire text, and click Insert->HTML, you can see what is happening in the background:

<font face="Helvetica, Arial, sans-serif">test<br>
<br>
</font>
<ol>
  <li>test</li>
</ol>
test

The font tag closes just before the ol tag opens.  

Expected Results:
The closing font tag should not be inserted until the very end of the email, or just before the signature.  As seen below:

<font face="Helvetica, Arial, sans-serif">test<br>
<br>
<ol>
  <li>test</li>
</ol>
test
</font>

Component: General → Message Compose Window
QA Contact: general → message-compose

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 250539
You need to log in before you can comment on or make changes to this bug.