Compose: Copy/pasted string doesn't display in subject/body when the field is empty

VERIFIED DUPLICATE of bug 41206

Status

MailNews Core
Composition
P3
normal
VERIFIED DUPLICATE of bug 41206
18 years ago
10 years ago

People

(Reporter: ji, Assigned: kinmoz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build: 2000060208 comm build
On mail compose window, Copy/pasted string doesn't display in subject/body when
the field is empty.

Steps of reproduce:
1. Launch Mail.
2. Copy a string from a mail or browser by using Edit|Copy menu or ctrl-c
short-cut key.
3. Bring up mail compose window
4. Don't type anything, set cursor on subject or body field, select Edit | paste
or
   press ctrl-v

The copy/pasted string doesn't display. But the string is actually there. 
Press Backspace, the string appears. Or swich the cursor focus to antoher window
and then come back to the mail compose window, the string appears too.

The follwoing JavaScript error shows on the console:
JavaScript error: 
 line 0: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIController.isCommandEnabled]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://global/content/globalOverlay.js :: goUpdateCommand :: line 230"  data:
no]

Comment 1

18 years ago
does this happen in composer (outside of mail)?
(Reporter)

Comment 2

18 years ago
No, it doesn't happen in html composer.

Comment 3

18 years ago
reassigning to beppe. I think this is an editor bug.  I see the same thing
happening in edit controls on pages like www.yahoo.com so it's not just in the
mail compose window.
Assignee: ducarroz → beppe

Comment 4

18 years ago
giving this to Kin for debugging
Assignee: beppe → kin
Target Milestone: --- → M16
(Assignee)

Comment 5

18 years ago
Accepting bug.
Status: NEW → ASSIGNED

Comment 6

18 years ago
I believe this is a dup of 41206, if it isn't, please reopen

*** This bug has been marked as a duplicate of 41206 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
I've verified as a duplicate and added a note in the other bug to try the mail
case when fixed.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.