Unifinder search is broken [Error: event is not defined]

VERIFIED FIXED in 0.8

Status

defect
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: ssitter, Assigned: Fallen)

Tracking

({regression})

Dependency tree / graph

Details

Attachments

(1 attachment, 1 obsolete attachment)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12pre) Gecko/2008012309 Calendar/0.8pre

Steps to Reproduce:
1. Start Sunbird with new clean profile
2. Create some new events in the near future
3. Use the search field in the unifinder to search for an event

Actual Results:
Unifinder is empty. Error Console shows:

  Error: event is not defined
  Source File: chrome://calendar/content/calendar-unifinder.js
  Line: 931

Expected Results:
Unifinder shows the events that match the search filter
Posted patch Fix v1 (obsolete) โ€” โ€” Splinter Review
Quite minimal, fix error and a warning.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #298797 - Flags: review?(ssitter)
Comment on attachment 298797 [details] [diff] [review]
Fix v1

r=ssitter

by the way: I noticed that the search results are not updated after editing an event to not match the search criteria anymore, i.e. the event is still visible but should not.
Attachment #298797 - Flags: review?(ssitter) → review+
Posted patch Fix v2 โ€” โ€” Splinter Review
This patch does the same as the previous patch and additionally addresses the issue you mentioned. I think we had this problem before though. Requesting ui-r since I'm not sure its wanted behavior that changed items vanish from the list immediately.
Attachment #298797 - Attachment is obsolete: true
Attachment #299481 - Flags: ui-review?(christian.jansen)
Attachment #299481 - Flags: review?(ssitter)
Comment on attachment 299481 [details] [diff] [review]
Fix v2

I think you can already checkin the regression fix. Unfortunately I don't have a build environment to test such a big patch compared to the two lines in the patch before.
Attachment #299481 - Flags: review?(ssitter) → review?(michael.buettner)
Blocks: 379100
Comment on attachment 299481 [details] [diff] [review]
Fix v2

r=christian
Attachment #299481 - Flags: ui-review?(christian.jansen) → ui-review+
Attachment #299481 - Flags: review?(michael.buettner) → review?(philipp)
Attachment #299481 - Flags: review?(philipp) → review?(Berend.Cornelius)
Comment on attachment 299481 [details] [diff] [review]
Fix v2

The patch looks very good to me. Even though I examined it very closely I could not detect anything wrong about it. r=berend.
Attachment #299481 - Flags: review?(Berend.Cornelius) → review+
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → 0.8
Verified using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12pre) Gecko/2008020220 Calendar/0.8pre.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.