new filter creation window doesn't popup when left-click 'create new filter' on a white-space/empty mail address

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: GuiHome, Unassigned)

Tracking

(Depends on: 2 bugs)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.11) Gecko/20071128 Iceweasel/2.0.0.11 (Debian-2.0.0.11-1)
Build Identifier: version 2.0.0.9 (20080110)

new filter creation window doesn't popup when left-clicking 'create new filter' on the "name" from/to/cc... with a white-space as mail address

example
to: myname <myname@foo.com> => works => creates filter with myname@foo.com
to: myname => works => creates filter with myname
to: myname <>  => doesn't work => should create filter with myname
to: myname < > => doesn't work => should create filter with myname

why this is needed ? 
to filter mail from mailing-list having a from/reply-to as foo-mailing-list < > to prevent from sending to it


Reproducible: Always

Steps to Reproduce:
1.create draft message with to:foo < >
2.save the message (send will fail except you have foo in your adress-book :-) )
3.select the message in draft and left-click on to:foo -> create new filter 
Actual Results:  
nothing happens

Expected Results:  
create filter window should popup with at least the name written in to/from/cc 

workaround is evident : Filter can still be edited by hand adding the name to filter in to/from/cc etc... 
but should be easy to fix

Comment 1

10 years ago
this is about all sys, os, etc. And goes for version 3.0a2 (2008072418) too.
But I would not be so sure is wrong. Basically it does not work with an non existing address. 
You may argue that it is looking for the address and not the name if you have some <> after it. But I see this as a fault in the format of the contact. Or I'd say works for me.

Is there a valid case other than this testing, where you actually received such email so that it stops you from filtering? even if scam, spam etc .

Note that in 3.0a2 when I edit draft with "foo <>" in to:, it presents an empty to: field. So it's obviously wrong from Tb pov.
OS: Linux → All

Comment 2

10 years ago
probably a duplicate of 369278, cause the idea is to understand both the name and address, but for now I only depend.
Depends on: 369278

Updated

10 years ago
No longer depends on: 369278

Updated

10 years ago
Depends on: 99997, 327621, 369278
(Reporter)

Comment 3

10 years ago
I may have used a wrong word in this sentence:

why this is needed ? 
to filter mail from mailing-list having a from/reply-to as foo-mailing-list < >
to prevent from sending to it

one should understand :
why this is needed ? 
to CREATE new mail filter from a mailing-list email having from/reply-to as "foo-mailing-list < >" . This happens when the mailing-list uses this format (maybe fault format i agree) as a workaround to prevent people from answering to this "read-only" mailing-list.

So this is a concrete but rare case. The problem happens only at creation (since no popup windows offers to create a new filter) not during filtering because filtering can still be done by hand using the name "foo-mailing-list" only.

Note sure it depends on 369278 because the correct behaviour would be at least to open the "new filter" popup window even if the form is not automatically filled.

Hope I could help for understanding things...
This WFM in 3.0.

Created a draft with to set to foo <>.

Went to my draft folders and was able to see the filter creation popup so this can be added.

Why not use the list-id to create you filter ?
(Reporter)

Comment 5

8 years ago
Hi,

  I could test this on the latest TB 3.0 on Windows. On my debian this version is not available yet.

The filter creation popups up correctly now. This was really minor but was not normal behaviour.

I can close this bug now. sorry for the delay. Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.