Ftp directory bookmark causes crash with personal toolbar menu

VERIFIED INVALID

Status

P3
normal
VERIFIED INVALID
19 years ago
14 years ago

People

(Reporter: suckfish, Assigned: slamm)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Adding a ftp bookmark to a bookmark folder, and then trying to bring up the
bookmark in the bookmarks menu on the personal toolbar causes the lizard to crash.

1.Create a bookmark folder.
2.Book mark a ftp directory.
3.Place ftp bookmark in folder.
4.Bring up the bookmarks menu on the personal toolbar, and go to the sub-menu
for the folder.
5.Close the menu and wait a few seconds.

The sub-menu is not displayed correctly.  Mozilla eventually crashes.

Also note the appearance of the bookmark in the sidebar bookmarks panel --- is
it really meant to have an open/close triangle?
(Reporter)

Comment 1

19 years ago
One more observation: the trailing '/' on the ftp URL appears to be necessary to
trigger this bug.

Comment 2

19 years ago
Adding crash to keyword field.
Keywords: crash

Comment 3

19 years ago
Linux 2000060508.

Ok... I've got several observations on this one, and there doesn't seem to be
any other bugs in bugzilla regarding FTP urls in the bookmarks.

First: When you add a trailing / to the URL and add that to the bookmarks, THEN
Mozilla makes the URL a folder and (I guess) plans to show the FTP directory
contents within the folder. Hmm, hope that description is clear. With NO
trailing slash, it just pretends like that FTP URL is just a regular bookmark
and just adds it as any URL... no special treatment or folder stuff.

Otherwise, I can't create a crash OR display the contents of the folders that
are created by the FTP URLs. In general, the bookmark management in my build
pretty much sucks, so I can't do much (including creating new folders, moving
items around, etc.).

I was unable to create any SEGFAULTS (crashes) during any of my playing around
with this bug, including following the reporters directions several times with a
couple of variations thrown in as well.

Comment 4

19 years ago
ftp directories as folder --> bug 41539 (which will prolly get closed b/c that's how it's supposed to work :-)
(Reporter)

Comment 5

19 years ago
I can't reproduce this any more.  So either it was originally a wierd glitch
on my machine, or it's been fixed anyway.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 6

19 years ago
marking VERIFIED
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.