copies hidden html to buffer in addition to selected html when i select html

RESOLVED DUPLICATE of bug 39098

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 39098
10 years ago
10 years ago

People

(Reporter: Trent, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2

I have chunks of HTML text that have property 'display: none', and are not displayed to the browser.  Yet when I select some of the visible HTML in the browser, firefox puts into the buffer all HTML text whether it is displayed or not. This is undesirable for me and I can't think of a reason why someone would want that functionality. The problem is not unique to Firefox 3, it also exists in firefox 2, but I was just hoping that the new release would change this. This problem doesn't happen with browsers Safari and Opera. 


Reproducible: Always

Steps to Reproduce:
1. Open page
2. Select text without clicking on any of the links and press Copy.
3. Paste it into any text editor and you will find more text than what you selected.
Actual Results:  
In addition to the selected text, all the in-between text (with property of 'display: none') is also displayed. 

Expected Results:  
It should only copy the text that is displayed on the browser, not the text that is hidden.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 39098
You need to log in before you can comment on or make changes to this bug.