Firefox leaks when FoxyProxy Extension is installed

RESOLVED FIXED

Status

()

Core
General
P4
normal
RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: Tomcat, Assigned: sicking)

Tracking

({memory-leak})

Trunk
x86
Mac OS X
memory-leak
Points:
---
Bug Flags:
wanted-next +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Created attachment 299018 [details]
leak log

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b3pre) Gecko/2008012408 Firefox/3.0b3pre

Steps to reproduce:
-> New Profile
-> Install the Foxy Proxy Extension https://addons.mozilla.org/en-US/firefox/addon/2464
-> i followed the default installation steps of this Extension
-> After the Extension is installed Firefox leaks

 0 TOTAL                                          29      396   217689        9 ( 1034.30 +/-  1545.58)   801819        8 ( 1450.66 +/-  2214.22)
Flags: blocking1.9?
Taking and marking blocking. However I suspect the leak won't build up over time since only a single instance of each object is leaked.

The nsRunnable leak is interesting though since I've seen that show up in many places. And I can't find where we actually log ctor/dtor of runnables.
Assignee: nobody → jonas
Flags: blocking1.9? → blocking1.9+
Priority: -- → P4
Flags: tracking1.9+
Flags: wanted-next+
Fixed in FoxyProxy version 2.17 and above.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.