Firefox disregard internal stylesheets with title attribute set

RESOLVED DUPLICATE of bug 188131

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 188131
11 years ago
11 years ago

People

(Reporter: VK, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: 

Firefox disregard internal stylesheets with title attribute set.


Reproducible: Always

Steps to Reproduce:
Save this HTML page an open in Firefox

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN">
<html>
<head>
<meta http-equiv="Content-Type"
 content="text/html; charset=iso-8859-1">
<title>Untitled Document</title>

<style type="text/css" title="sheet01">
body {
 background-color: silver;
}

</style>

<style type="text/css" title="sheet02">
p {
 font-size: 2em;
 color: red;
}

</style>

</head>
<body>
<p>Test</p>
</body>
</html>
Actual Results:  
Only the first internal stylesheet with title (setting page background) is used. 
The second internal stylesheet (setting P style) is silently ignored.

Expected Results:  
Both internal stylesheets must be used.

http://www.w3.org/TR/html4/present/styles.html#h-14.3 handles exclusively _external_ stylesheets over <link>. For internal stylesheet it has no application.
(Reporter)

Comment 1

11 years ago
Created attachment 299035 [details]
HTML file demonstrating the bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 188131
You need to log in before you can comment on or make changes to this bug.