mouse pointer position on awesome bar results overrides keyboard typing

VERIFIED DUPLICATE of bug 408723

Status

()

Firefox
Address Bar
--
major
VERIFIED DUPLICATE of bug 408723
10 years ago
10 years ago

People

(Reporter: pascalc, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9b3pre) Gecko/2008012104 Minefield/3.0b3pre ID:2008012104

(I hope the title of the bug is clear enough, feel free to update it if you find a better wording)

When you type an URL in the location bar, results proposals are displayed in the drop down list. If the mouse pointer was in this area before going to the location bar, hitting enter in the location bar is not going to lead you to the url you typed but to the result proposal your mouse pointer is on.

1/ have the mouse pointer on a page somewhere below the location bar
2/ type CTRL+L to go to the location bar
3/ type google.com
4/ hit enter

Expected result:
go to google home page

actual result:
you go to the google page that was in the location bar results and that happened to have your mouse pointer on it.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 408723
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.