Closed Bug 413979 Opened 13 years ago Closed 13 years ago

Blank entry in smart bookmarks dropdown where page has no <title> specified

Categories

(Firefox :: Bookmarks & History, defect)

x86
All
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 412348

People

(Reporter: gidsgoldberg, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3pre) Gecko/2008012404 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3pre) Gecko/2008012404 Minefield/3.0b3pre

Where a page has no <title> specified it appears in the Smart Bookmarks dropdown as a blank entry. To identify the URL the user seemingly needs to launch the 'Library' (Ctrl+Shift+B) and look in the Location field.


Reproducible: Always

Steps to Reproduce:
1.Make a page with no <title> one of your most visited pages
2.On the Bookmarks Toolbar select Smart Bookmarks > Most Visited
3.Look for the entry 
Actual Results:  
Entry is blank, no feedback as to where the bookmark points to

Expected Results:  
name of the bookmark should be the URL
Version: unspecified → Trunk
Could you give a URL with the problem?
This occurred when migrating my profile to places, my most visited link is an intranet page with no title, the URL ends in a port number. This showed up as blank, but visiting the same page with a fresh profile in trunk build, shows the URL, so it looks like this is a profile migration issue.

(In reply to comment #1)
> Could you give a URL with the problem?
> 

Depends on: 419216
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 419216
I think bug 412348 is the better dupe, if what you're seeing is with migrated bookmarks.
(In reply to comment #4)
> I think bug 412348 is the better dupe, if what you're seeing is with migrated
> bookmarks.
> 

could be one of them, bug 419216 has fixed all menus and treeviews with empty titles. bug 412348 is mostly for dropdown, there are no enough info to check what is the real cause between the two... if you think that's better bug 412348 due to the import, feel free to change the dupe
Gids, if this is with a new no title bookmark then the dupe is as it is now. but if you're seeing this with migrated bookmarks then the dupe is 412348. In your original report is seems to be with new ones.  but then you made comment #2.  I'll leave duped per your original report
Status: RESOLVED → VERIFIED
(In reply to comment #6)
Thanks for the follow-up Tracy and sorry for the late reply. 
Yes, whilst I initially thought this applied to all bookmarks, I later realised this only occurred when migrating my profile, so I think this bug is a dupe of bug 412348. 

Status: VERIFIED → RESOLVED
Closed: 13 years ago13 years ago
Duplicate of bug: 412348
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.