If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

directTypeRadio.label in the connection preferences dialog should be "no proxy" rather than "direct connection"

VERIFIED FIXED in Firefox 3 beta5

Status

()

Firefox
Preferences
P3
normal
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: Paul Lacourse, Assigned: Cédric Corazza)

Tracking

({late-l10n})

Trunk
Firefox 3 beta5
late-l10n
Points:
---
Bug Flags:
blocking-firefox3 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.8.1) Gecko/20061010 Firefox/2.0 VRE Toolbar 1.42
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9b3pre) Gecko/2008012404 Minefield/3.0b3pre

The preference label <!ENTITY  proxyTitle.label              "Configure Proxies to Access the Internet"> should not contain the term "Proxies" as the first option ins't related to proxy.
<!ENTITY  directTypeRadio.label         "Direct connection to the Internet">
I would suggest something more general like "Configure the connection to access the internet" 

Ref. http://mxr.mozilla.org/mozilla/source/browser/locales/en-US/chrome/browser/preferences/connection.dtd#6

Reproducible: Always

Steps to Reproduce:
1. Menu Tools/Options/Advance/Network
2. 
3.
(Assignee)

Comment 1

10 years ago
Created attachment 299777 [details] [diff] [review]
Patch rewording the proxy caption

If this bug is accepted, I will file the other three depending bugs for Thunderbird, Sunbird/Lightning and the Suite
Assignee: nobody → cedric.corazza
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #299777 - Flags: review?(gavin.sharp)
(Assignee)

Updated

10 years ago
Flags: blocking-firefox3?
OS: Windows XP → All
Priority: -- → P3
I don't really think this is a bug. "Direct connection" just means "no proxy", and that pane *is* only used to set up proxies. The fact that the default option doesn't contain the string "proxy" doesn't really mean there's a problem with the title.
(Assignee)

Comment 3

10 years ago
(In reply to comment #2)
> I don't really think this is a bug. "Direct connection" just means "no proxy",
> and that pane *is* only used to set up proxies. The fact that the default
> option doesn't contain the string "proxy" doesn't really mean there's a problem
> with the title.
Well, I'm not very eager to fix this bug, but I saw so *many* "nit" bugs (we've got a very colourful expression in French to qualify those kind of bugs which is not suitable here :) ) being approved, that I think this one could be too. In fact, in the Prefs Advanced Panel > Connection > (Configure how &brandShortName; connects to the Internet) > Settings… menus, there is no mention about proxies at all, and even the title of the window doesn't mention that (Connection Settings).
And this pane is not used for "proxy" settings, but for "Internet connection settings".
But well, I won't lead a war to get this fixed :) .
imho, this kind of bug will not disturb people who don't notice that, is safe enough to be checked-in and could please the contributors.
Of course, there's no hurry about this for the beta3 release, but RC1 could be the milestone for this, without jeopardizing the release process.

Comment on attachment 299777 [details] [diff] [review]
Patch rewording the proxy caption

(In reply to comment #3)
> Well, I'm not very eager to fix this bug, but I saw so *many* "nit" bugs (we've
> got a very colourful expression in French to qualify those kind of bugs which
> is not suitable here :) ) being approved, that I think this one could be too.

It's not that I think it's a minor issue; I just don't think it's an issue at all.

Either way, this patch isn't correct, "Configure the Connection to Access the Internet" doesn't make sense.
Attachment #299777 - Flags: review?(gavin.sharp) → review-
(Reporter)

Comment 5

10 years ago
It may not make sense for others (people who knows what's behind that dialog box) but in french having it this way doesn't make sens either. It is counter logical. We have to twist our mind to understand it.
From my point of view, if it make sense as is in English, why not just fix it the way we want in French and leave the English version as is.
(In reply to comment #5)
> It may not make sense for others (people who knows what's behind that dialog
> box) but in french having it this way doesn't make sens either. It is counter
> logical. We have to twist our mind to understand it.

I speak french, and the strings in http://lxr.mozilla.org/l10n-mozilla1.8/source/fr/browser/chrome/browser/preferences/connection.dtd don't seem particularly problematic to me. We could change the first option's label to be something more like "no proxy (direct connection)", if that would help? I still don't really understand the problem.
(Reporter)

Comment 7

10 years ago
I wont war at anybody but, yes your suggestion somehow make sense.
Maybe it is not the same in the previous dialog in English, but in french we have the *Connection* section under the network tab then "Configure the way Firefox connect to the Internet" and then a button with the label "Parameters...". From that dialog, there is no trace of proxy yet. (We are talking about the connection to the internet.) 

The first time I saw that dialog, even if I wasn't a newbie, and the fact that by default Firefox is set to connect without Proxy and the other fact that I was able to browse the web already through a NAT wireles router I understood that, in the dialog that interest us here, "Direct connexion" in the context of that dialog was meaning "Connecting directly, through an ICS (Internet Connection Sharing WinXP) or through a NAT router". This sentence is way too long and would probably lead to even more confusion so yes your idea of saying "No proxy" as the first option could help making that dialog clearer. I would not put the "(direct connexion)". Just "No Proxy" would be alright for me.
Alright. Morphing the bug to be about changing the string to "No proxy". Since we're past the Firefox 3 string freeze, I don't think we're likely to take minor changes like this one, but we can certainly take the patch for the trunk once we branch/switch to Hg/whatever.
Summary: Preferences proxyTitle.label should not contain the term Proxy → directTypeRadio.label in the connection preferences dialog should be "no proxy" rather than "direct connection"
This does not block the final release of Firefox 3.
Flags: blocking-firefox3? → blocking-firefox3-
(Assignee)

Comment 10

10 years ago
Created attachment 303550 [details] [diff] [review]
Patch addressing Gavin's comment
Attachment #299777 - Attachment is obsolete: true
Attachment #303550 - Flags: review?(gavin.sharp)
Comment on attachment 303550 [details] [diff] [review]
Patch addressing Gavin's comment

I think this might read better as "Don't use a proxy", given the other strings used for the radio buttons. The ui-reviewer can provide some input I guess - this is fine technically.

As I said in my previous comment, I'm not sure this is worth taking now that we're past string freeze.
Attachment #303550 - Flags: review?(gavin.sharp) → review+
(Assignee)

Updated

10 years ago
Attachment #303550 - Flags: ui-review?(beltzner)
Comment on attachment 303550 [details] [diff] [review]
Patch addressing Gavin's comment

uir+a=beltzner, please mark late-l10n
Attachment #303550 - Flags: ui-review?(beltzner)
Attachment #303550 - Flags: ui-review+
Attachment #303550 - Flags: approval1.9+
Keywords: checkin-needed
This missed string freeze... Would it be possible to land it after b4?
Keywords: late-l10n
I don't think it's worth the trouble, as I said in comment 8 and comment 11.
Keywords: late-l10n
Keywords: checkin-needed
Keywords: checkin-needed
Keywords: late-l10n
Checking in browser/components/preferences/connection.xul;
/cvsroot/mozilla/browser/components/preferences/connection.xul,v  <--  connection.xul
new revision: 1.13; previous revision: 1.12
done
Checking in browser/locales/en-US/chrome/browser/preferences/connection.dtd;
/cvsroot/mozilla/browser/locales/en-US/chrome/browser/preferences/connection.dtd,v  <--  connection.dtd
new revision: 1.10; previous revision: 1.9
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 beta5
Version: unspecified → Trunk
(Assignee)

Comment 16

10 years ago
Verified.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008030806 Minefield/3.0b5pre
Status: RESOLVED → VERIFIED

Comment 17

10 years ago
noProxyTypeRadio.accesskey now conflicts with shareproxy.accesskey (both are "x").
(Assignee)

Comment 18

10 years ago
Created attachment 308287 [details] [diff] [review]
Patch fixing accesskeys collision

This one fixes accesskeys collision. As it only concerns en-US, there should be no problem with the string freeze, right?
Attachment #303550 - Attachment is obsolete: true
Attachment #308287 - Flags: review?(gavin.sharp)
Attachment #308287 - Flags: review?(gavin.sharp)
Attachment #308287 - Flags: review+
Attachment #308287 - Flags: approval1.9?

Updated

10 years ago
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Comment on attachment 308287 [details] [diff] [review]
Patch fixing accesskeys collision

a1.9+=damons
Attachment #308287 - Flags: approval1.9? → approval1.9+
(Assignee)

Updated

10 years ago
Keywords: checkin-needed
Checking in browser/locales/en-US/chrome/browser/preferences/connection.dtd;
/cvsroot/mozilla/browser/locales/en-US/chrome/browser/preferences/connection.dtd,v  <--  connection.dtd
new revision: 1.11; previous revision: 1.10
done
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
(Assignee)

Comment 21

10 years ago
Verified. Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008031111 Minefield/3.0b5pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.