Files of the same version with different statuses can be displayed prematurely

RESOLVED DUPLICATE of bug 558237

Status

addons.mozilla.org Graveyard
Public Pages
P3
normal
RESOLVED DUPLICATE of bug 558237
10 years ago
2 years ago

People

(Reporter: fligtar, Unassigned)

Tracking

4.x (triaged)

Details

(URL)

(Reporter)

Description

10 years ago
PicLens has had a Windows-only version for awhile and recently added a Mac version. The Windows file was approved and the Mac version was still pending review, yet on the public display page, the Mac version was showing up. Because the file hadn't been copied to the mirror, it was returning a download error.

The Mac version shouldn't show up if it's not public.

Comment 1

10 years ago
I also have an extension where the linux version has been released but the windows version is still in the sandbox, however the green button shows as if it is available.
https://addons.mozilla.org/en-US/firefox/addon/5764
When you click on the green install button from windows firefox produces a dialog:
Firefox could not install the file at
https://addons.mozilla.org/en-US/firefox/downloads/file/23623/zinc-0.6.3.0-fx-
win.xpi
because: Invalid file hash (possible download corruption) -261
This is because the supplied file is an html redirection page for accessing the sandbox rather than xpi itself, but the xpi installer doesn't handle this.

Updated

9 years ago
Target Milestone: --- → 3.x (triaged)
Priority: -- → P3
That'll be fixed in Zamboni: bug 558237.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 558237
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.