Thunderbird cannot delete folder on IMAP server

RESOLVED DUPLICATE of bug 357911

Status

MailNews Core
Networking: IMAP
RESOLVED DUPLICATE of bug 357911
10 years ago
9 years ago

People

(Reporter: Andrew Daviel, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: 2.0.0.9

After the following IMAP exchange, the icon for "junk2" disappears from the
folder view. On restarting Thunderbird, it reappears (since it is still
present on the server)
* LIST (\HasNoChildren) "/" Trash/junk2/
5 OK LIST completed
6 delete "Trash/junk2/"
6 NO Can't lock mailbox for delete: Trash/junk2/
7 IDLE


Reproducible: Always

Steps to Reproduce:
1. Right-click folder "Trash/junk2"
2. Select "Delete"

Actual Results:  
Icon for folder disappears, as if it had been successfully deleted.
On exit and reconnect, Thunderbird checks for subscribed folders and
the icon reappears.

Expected Results:  
Icon for folder remains. Warning popup displays IMAP error message, or otherwise
advises user that delete operation failed

This happens with current (imapd-2007) UW IMAP server. Reason for locked
mailbox under investigation; does not happen with Pine mail client. The real problem is that Thunderbird cannot delete a MIX format folder; the bug reported here is that Thunderbird thinks the delete worked.
Assignee: nobody → bienvenu
Component: General → Networking: IMAP
Product: Thunderbird → Core
QA Contact: general → networking.imap
(Reporter)

Comment 1

10 years ago
I reported this problem to the IMAP server maintainer. He says that the
underlying problem is that you can not delete a mailbox that is currently open (including by yourself). I changed the summary line accordingly.

If "mark as deleted" or "delete immediately" is selected, the error
occurs immediately (apparent after restart). If "move to Trash" is selected,
the unwanted folder is successfully moved with a rename operation. But
"empty trash" fails.

A fuller command log from the above report is:

3 select "Trash/junk2"
* 0 EXISTS
* 0 RECENT
* OK [UIDVALIDITY 1178927324] UID validity status
* OK [UIDNEXT 1] Predicted next UID
* FLAGS (\Answered \Flagged \Deleted \Draft \Seen)
* OK [PERMANENTFLAGS (\* \Answered \Flagged \Deleted \Draft \Seen)] Permanent flags
3 OK [READ-WRITE] SELECT completed
4 IDLE
+ Waiting for DONE
DONE
4 OK IDLE completed
5 list "" "Trash/junk2/*"
* LIST (\HasNoChildren) "/" Trash/junk2/
5 OK LIST completed
6 delete "Trash/junk2/"
6 NO Can't lock mailbox for delete: Trash/junk2/

Component: Networking: IMAP → General
Product: Core → Thunderbird
Summary: If IMAP server cannot delete a folder, Thunderbird ignores error status and shows it as deleted → Thunderbird cannot delete folder on IMAP server
Version: unspecified → 2.0
Please do not change the Product/comonent to a wrong one.

Component: General → Networking: IMAP
Product: Thunderbird → Core
Version: 2.0 → unspecified
(Reporter)

Comment 3

10 years ago
sorry (re product change) - thought I'd misfiled it originally.

Looks like a duplicate of 357915, 357911 from October 2006.

Workaround: use a different mail client (Pine, Squirrelmail) to delete folders.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 357915
(In reply to comment #4)

Bug 357915 focuses on "no error message by Tb" when "NO to delete".
But Bug 357911 focuses on "NO to delete" itself by UW-IMAP when MIX format folder.
Wayne Mery, I think this bug is better to be DUP'ed to Bug 357911.
What do you think?

Comment 6

9 years ago
(In reply to comment #5)
> (In reply to comment #4)
> 
> Bug 357915 focuses on "no error message by Tb" when "NO to delete".
> But Bug 357911 focuses on "NO to delete" itself by UW-IMAP when MIX format
> folder.
> Wayne Mery, I think this bug is better to be DUP'ed to Bug 357911.
> What do you think?

I trust your judgment :)
Changing dupe to bug 357911
Duplicate of bug: 357911
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.