Closed Bug 414114 Opened 14 years ago Closed 13 years ago

Identity display (for EV certs) clutters the location bar, leaving little room for URL

Categories

(Firefox :: Address Bar, defect)

3.0 Branch
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 429722

People

(Reporter: u294409, Unassigned)

References

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9b3pre) Gecko/2008012504 Fedora/8 (Werewolf) Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9b3pre) Gecko/2008012504 Fedora/8 (Werewolf) Minefield/3.0b3pre

I've opened SourceForge's login page and I saw clutter in my location bar.

Reproducible: Always

Steps to Reproduce:
1. open some ssl-verified page
Actual Results:  
clutter in locationbar, useless info displayed

Expected Results:  
no clutter!
Attached image sf.net screenshot
Attached image bugzilla screenshot
By design -> invalid.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
So, the design is wrong.
Look at screenshots. It takes big part of my location bar. This info is totally USELESS!
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---
The only thing useless is your attitude and demeanor - as you've so spectacularly proven in quite a few bugs already. Keep it up and you'll soon find yourself without a bugzilla account.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → INVALID
look, it's a dupe of bug 413934
(In reply to comment #6)
> look, it's a dupe of bug 413934
> 

no it's not.
It's not because here it fits but it uses LOTS of space used by locationbar.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
I see something like this on SourceForge and PayPal but not on Bugzilla.  I'm guessing the difference is that Bugzilla doesn't have an EV cert.  I wonder why you're seeing it even on Bugzilla.
Summary: location bar displays useless info and makes clutter → Identity display (for EV certs) clutters the location bar, leaving little room for URL
I saw this once.
(In reply to comment #10)
> I saw this once.

It was disabled for beta1 in bug 402260. The current discussion about the future presentation is in bug 406612, so it might make sense to discuss this over there.
It's not about disabled or enabled.
When I saw this on sf.net and then I've visited bugzilla to file bug, only on /process_bug.cgi this useless info has shown, and I've captured it on screenshot.
If you set the pref 'browser.identity.ssl_domain_display' in about:config to 0, doesn't it not show the domain at all? (see attachment 299312 [details] [diff] [review] from bug 406612)

Or does that not work on EV sites?
(In reply to comment #13)
> If you set the pref 'browser.identity.ssl_domain_display' in about:config to 0,
> doesn't it not show the domain at all? (see attachment 299312 [details] [diff] [review] from bug 406612)
> 
> Or does that not work on EV sites?

Oops, I wasn't looking at the screenshots very carefully :/

So it sounds like this bug is asking for a pref to turn off the display of company and country info on EV sites?
Yes, I want to disable ALL that unuseful info.
Also, I wish for such option in GUI...
My temptation is to WONTFIX this bug due to Jakub's attitude, but the bug itself is valid: long OU names in EV certs can end up pushing the URL out of view which is a potential problem.

The following solutions (proposed in this bug) are WONTFIX:
 - GUI option to disable EV display 
 - hidden pref to disable EV display

The following solutions (from bug 406612) are viable options:
 - middle truncating the OU name with an ellipsis (though, worth noting that OU names are already limited to 64 characters)
 - collapsing to just the favicon after a timeout and re-expanding on hover (I suspect a performance hit!)
 - collapsing to just the favicon and not re-expanding (again, perf hit potential)

Jakub: fair warning, if you keep being argumentative and angry, I'll WONTFIX this bug and move the conversation somewhere else. Let's stay on topic, and talk about ways to solve the problem.

Johnath: any thoughts?
Status: UNCONFIRMED → NEW
Ever confirmed: true
browser.identity.ssl_domain_display=0 doesn't hide useless info.
(In reply to comment #17)
> browser.identity.ssl_domain_display=0 doesn't hide useless info.

What "useless info" does it not hide? It hides the domain prefix in the URL bar, which is what you originally filed this bug about...
(In reply to comment #18)
> (In reply to comment #17)
> > browser.identity.ssl_domain_display=0 doesn't hide useless info.
> 
> What "useless info" does it not hide? It hides the domain prefix in the URL
> bar, which is what you originally filed this bug about...

Jakub will correct me if I'm wrong, but I believe he's asking for some way to hide the company and country information which is displayed on EV sites (e.g. VA Software Corporation (US) in attachment 299407 [details]).
Exactly.
What about moving the EV display? It's kind of awkward to divide up one text box into two things. If that is WONTFIX, I would like to know why.
Kai - aside from the discussion in this bug, do you know why bugzilla would be showing EV treatment in Jakub's screenshot?  Bugzilla presents an Equifax cert, and is not EV.  It gets DV treatment from me on Mac and Windows on current builds - but if Jakub is seeing that without altering his code, then it seems like the progress listener might be getting the wrong return codes in some cases?
(In reply to comment #22)
> do you know why bugzilla would be
> showing EV treatment in Jakub's screenshot?

bug 402574 comment 10
I still want to know how to disable this info, which clutters my location bar.
Jakub, as of today, it's not possible to hide it.
You ought to be able to hide it by means of a "display:none" rule in userChrome.css; DOM Inspector should help you find which selector to use.

Note that I said "ought to be able to", not "can". If you cannot do it that way, it may mean lack of a proper distinct element to hold that info, and/or lack of a recognisable ID or class.
Duplicate of this bug: 422282
#identity-icon-label {
	color: rgba(0, 255, 0, 0.25);
	width: 1.5em;  
	overflow: hidden;
}

An icon would be better, though.
Maybe little Larry on adequate background? Green on green bg, etc.
OS: Linux → All
Hardware: PC → All
Version: unspecified → 3.0 Branch
(In reply to comment #16)
> The following solutions (from bug 406612) are viable options:
>  - middle truncating the OU name with an ellipsis (though, worth noting that
> OU names are already limited to 64 characters)

That's the solution I would prefer (note that it's the "O"/organizationName attribute, more precisely).

Imagine the Hypovereinsbank (one of Germany's largest banks) would switch to EV certificates - this would look quite clumsy in Firefox on a 1024px screen... see attachment (upper half, Vista and Leopard, on the latter it's even worse).

Maybe something similar to IE7? It limits the display of the organizationName to about 250px, and it will scale down proportionally if the user decreases the width of the browser window (see attachment, lower half).

In my opinion, the identity-icon-label should not take up more than half of the "urlbar-container" toolbaritem (except if the complete location string takes less than 50% to be shown in its entirety).

What Firefox could do better than IE7, actually, is end-truncating the organizationName only - i.e., instead of "Bayerische Hypo- und Vereinsbank Aktienge..." it would e.g. show "Bayerische Hypo- und Verein... (DE)". This would mean separating the identity-icon-label into two parts, is that correct (the first one using crop="end")?
> Imagine the Hypovereinsbank (one of Germany's largest banks) would switch to
> EV certificates - this would look quite clumsy in Firefox on a 1024px
> screen...

FWIW, this has happened in the meantime (without any involvement from my side, NB).

> In my opinion, the identity-icon-label should not take up more than half of
> the "urlbar-container" toolbaritem (except if the complete location string
> takes less than 50% to be shown in its entirety).

Attachment 332188 [details] [diff] has addressed this issue, so it's probably best to resolve this bug as a dupe.

> What Firefox could do better than IE7, actually, is end-truncating the
> organizationName only - i.e., instead of "Bayerische Hypo- und Vereinsbank
> Aktienge..." it would e.g. show "Bayerische Hypo- und Verein... (DE)".

I still consider this the better solution than (mechanically) middle truncating the organization name - will add a comment to bug 429722.
Status: NEW → RESOLVED
Closed: 14 years ago13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429722
You need to log in before you can comment on or make changes to this bug.