Send attachments causes hang when FILETOSEND not in URL format for -compose attachment=FILETOSEND

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
--
critical
RESOLVED INVALID
11 years ago
8 years ago

People

(Reporter: Michael Buckley, Unassigned)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: version 2.0.0.9 (20071031)

If some program passes a file path like this one to Thunderbird to handle as an attachment in a new message it seams to hang when you try to save to send the message.  I am sure it has something to do with the ~1 folder names not be resolved right.

C:\DOCUME~1\Owner\LOCALS~1\Temp\1201352880308.htm

Reproducible: Always

Steps to Reproduce:
1.Go to the command line
2.type
 thunderbird -compose attachment=C:\DOCUME~1\Owner\LOCALS~1\Temp\1201352880308.htm
3. send message, it hangs when attaching the file.


Expected Results:  
It should send the message like normal.

Comment 1

10 years ago
(In reply to comment #0)

This is an incomplete bug report....
I had a similar , thought it was possibly due to the '~', so i changed the paths.
thunderbird  -compose subject=Invoice,attachment=c:\temp\inv11045.pdf
The attachment shows in the attachment window with the full path displayed.
(normal attachments don't)
1) This attachment cannot be double clicked to open
2) If the email is saved then it hangs with 'attaching file ........'
   although the progress bar keeps cycling.
3) When trying to send , the same thing happens.
This appears to be an issue with the command line processing of the 'attachment=' parameter



> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11)
> Gecko/20071127 Firefox/2.0.0.11
> Build Identifier: version 2.0.0.9 (20071031)
> 
> If some program passes a file path like this one to Thunderbird to handle as an
> attachment in a new message it seams to hang when you try to save to send the
> message.  I am sure it has something to do with the ~1 folder names not be
> resolved right.
> 
> C:\DOCUME~1\Owner\LOCALS~1\Temp\1201352880308.htm
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.Go to the command line
> 2.type
>  thunderbird -compose
> attachment=C:\DOCUME~1\Owner\LOCALS~1\Temp\1201352880308.htm
> 3. send message, it hangs when attaching the file.
> 
> 
> Expected Results:  
> It should send the message like normal.
Flags: wanted-thunderbird3?
(In reply to comment #0)
> 2.type
>  thunderbird -compose attachment=C:\DOCUME~1\Owner\LOCALS~1\Temp\1201352880308.htm

One of repeatedly opened bugs at bugzilla.mozilla.org...

See following document.
> https://developer.mozilla.org/en/Command_Line_Options
> -compose message_options
> Link of : See "syntax rules"
> https://developer.mozilla.org/en/Command_Line_Options#Syntax_Rules
>   attachment='file:///c:/test.txt
As seen in above, attachment keyword data should be URL format(file: URL when local file).

=> INVALID

FYI.
"manual conversion to URL(file: url when local file)" is difficult when non-asci local file name(UTF-8 should be used). AFAIR, enhancement like next was discussed in similar bug to this bug, for ease of command line use.
  - Enhance "attachment parameter" to accept local file path format
    specified in charset of system locale.
  - New parameter data format(non-URL format).
    For example, attachment="LOCAL_FILE=C:\xxx\...\yyy.zzz".
  - New parameter. For example, attachment_local="C:\xxx\...\yyy.zzz".
Sorry but I couldn't recall bug number.
However, because small script or batch can be a very easy/simple solution, bug for enhancement was not opened.

Note:
Tb requires file: url of escaped UTF-8, if file path contains non-ascii character. Even when browser issues 'thunderbird.exe -compose attachment="file://..."', some browsers pass file: url of non-escaped format of non-asci data, and some browsers pass file: url of escaped format but non-UTF-8 data. It is different issue from this bug, and is already known issue.
Reporter what think about comment #1 and\or comment #2?
(Reporter)

Comment 4

9 years ago
@comment #3

Oh I accept the explanation, just the little program I was using did not seam to know about file:// urls so it was causing the problem.
Close as invalid per comment #4.

Feel free to reopen it if I'm wrong.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Flags: wanted-thunderbird3?

Updated

8 years ago
Keywords: hang
Summary: Send attachments to Thunderbird with ~1 in the path causes it to hang when sending. → Send attachments causes hang when FILETOSEND not in URL format for -compose attachment=FILETOSEND
You need to log in before you can comment on or make changes to this bug.