on popup, address-bar autocomplete automatically selects item under mouse cursor

VERIFIED DUPLICATE of bug 408723

Status

()

Firefox
Address Bar
VERIFIED DUPLICATE of bug 408723
11 years ago
11 years ago

People

(Reporter: Thiago Teixeira, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2) Gecko/2007121016 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2) Gecko/2007121016 Firefox/3.0b2

When entering text in the location bar, the autocomplete popup should not automatically select the item under the cursor (unless the mouse moves). The topmost item (ie. the best match) should be the one selected.

Reproducible: Always

Steps to Reproduce:
1. Place mouse cursor somewhere below the address bar. It's best if you imagine where the autocomplete popup would show up and place the cursor there right on top of that area.
2. Hit Alt-D or Ctrl+L to jump to address bar.
3. Type anything in address bar to cause address bar history popup to appear.  Do not press enter.
4. Once the popup appears, you'll notice that item under the mouse cursor is selected. (This happens about 50% of the times with me, so you may have to try steps 1-4 again. I believe that if your cursor is over a non-text area of the popup it will not automatically select the item below it -- which is the desired behavior)
5. Press ENTER

Actual Results:  
The page that was selected under the mouse cursor will load.

Expected Results:  
The best matching page (at the top of the popup) should load.
(Reporter)

Comment 1

11 years ago
Just to clarify: in step (1), when I say "place the cursor right on top of that area" I mean "place the cursor *inside* that area.

I meant "on top" in the z-order sense...
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008012604 Minefield/3.0b3pre

I can't reproduce this on Windows. Only if the mouse is accidentally moving a bit. 

Comment 3

11 years ago
Confirmed -
Build Info:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2008012604 Minefield/3.0b3pre

Leaving as unconfirmed to make sure we have at least one more confirmation in a linux environment.
I can confirm as well on linux.

Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9b3pre) Gecko/2008012604 Minefield/3.0b3pre
Changing status to NEW, based on comment 3 and comment 4.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 408723
Verified dup
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

11 years ago
Yes, this is a duplicate. I hadn't found that post in my search before. Sorry about that.
You need to log in before you can comment on or make changes to this bug.