Marking text in code-field by double-click causes firefox to hang-up

RESOLVED INVALID

Status

()

RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: saula, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

If I mark a text by double-click on it on the given URL, Firefox hangs-up.
There must be something special on the given URL, because it doesn't appear in other code-fields in other postings at the website.

Reproducible: Always

Steps to Reproduce:
1. Open http://board.perl-community.de/thread/11191/#MSG5
2. Double-Click on a Word in code-file after Perl:

Actual Results:  
Firefox hangs-up

Comment 1

11 years ago
Works for me, Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

Thomas, does the problem occur also in Firefox Safe Mode?
(it temporarily disables add-ons and themes, this test will help us narrow
down the cause of the problem) --  See http://kb.mozillazine.org/Safe_Mode

Please explain what you mean by "hangs-up".
Does all Firefox windows disappear? (crash)
or do they remain on screen but not respond? (hang)

In case of crash:
Does the Talkback window pop up when the crash occurs?
If so, please submit the crash data and let us know the incident ID. Thanks.
http://kb.mozillazine.org/Quality_Feedback_Agent
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)

> Thomas, does the problem occur also in Firefox Safe Mode?
> (it temporarily disables add-ons and themes, this test will help us narrow
> down the cause of the problem) --  See http://kb.mozillazine.org/Safe_Mode

No, in Safe Mode the problem doesn't occur.
I've located the problem only occurs when then Firefox Addon "Linkifikation 1.3.3" is activated.

> Please explain what you mean by "hangs-up".
> Does all Firefox windows disappear? (crash)
> or do they remain on screen but not respond? (hang)

It remains on screen an does not respond.

The Problem occurs only in the code Window of the first Posting (26.01.2008 um 14:13:48) in the given URL (on Page 1).

Comment 4

11 years ago
The problem also occurs in a trunk build.
I don't think it's a bug in Firefox, it's the add-on that executes very
expensive xpath expressions for every node in the DOM.

Thomas, please notify the maintainers of this add-on of the problem. Thanks.

-> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.