"ASSERTION: row count did not change by the amount suggested, check caller"

RESOLVED DUPLICATE of bug 479931

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 479931
11 years ago
6 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
x86
Mac OS X
assertion, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sg:dupe 479931?])

Attachments

(2 attachments)

471 bytes, application/vnd.mozilla.xul+xml
Details
6.99 KB, text/plain
Details
(Reporter)

Description

11 years ago
Created attachment 299480 [details]
testcase

Loading the testcase triggers:

###!!! ASSERTION: row count did not change by the amount suggested, check caller: 'rowCount == mRowCount', file /Users/jruderman/trunk/mozilla/layout/xul/base/src/tree/src/nsTreeBodyFrame.cpp, line 1817

WARNING: row count changed unexpectedly: 'mRowCount == rowCount', file /Users/jruderman/trunk/mozilla/layout/xul/base/src/tree/src/nsTreeBodyFrame.cpp, line 2764

###!!! ASSERTION: bad index: 'aIndex >= 0 && aIndex < mRows.Count()', file /Users/jruderman/trunk/mozilla/layout/xul/base/src/tree/src/nsTreeContentView.cpp, line 284

The "bad index" assertion is covered by bug 366203, but the "row count did not change by the amount suggested" assertion doesn't seem to be covered by other bug reports.

Comment 1

11 years ago
Looks to me that ContentInserted needs to call InsertRowFor to deal with <option> correctly (it already does that for treeitem/treeseparator/optgroup).

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: xptoolkit.trees → xptoolkit.widgets
(Reporter)

Comment 2

9 years ago
Created attachment 396612 [details]
crash stack

The testcase crashes on trunk [@ nsTreeContentView::InsertRow].
(Reporter)

Comment 3

9 years ago
Like bug 479931.
Group: core-security

Comment 4

9 years ago
This looks like a straight duplicate to me; the only difference I noticed is that there's a slightly different non-tree node in the tree. The crash would probably occur with a text node if you cared to give it a try.
(Reporter)

Updated

9 years ago
Depends on: 479931
Whiteboard: [sg:dupe 479931?]
Looks like a duplicate to me too. The patch in bug 479931 fixes this.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 479931
Group: core-security
You need to log in before you can comment on or make changes to this bug.