getBoundingClientRect is broken for tables

RESOLVED DUPLICATE of bug 414190

Status

()

RESOLVED DUPLICATE of bug 414190
11 years ago
9 years ago

People

(Reporter: roc, Assigned: roc)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

getBoundingClientRect returns the dimensions of the table outer frame, which is wrong (for example, includes margins) and incompatible with IE.

For IE compatibility, getBoundingClientRect should return the union of the table inner frame border-box and the caption border-box and getClientRect should return that same rectangle. For continuations we'll need to work a little harder.
Flags: blocking1.9?
Sorry about the dup ... I thought my browser had crashed filing this one and didn't realize it had gone through.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 414190
Flags: blocking1.9?
You need to log in before you can comment on or make changes to this bug.