Preferences header has broken appearance in linux builds

RESOLVED FIXED in Thunderbird 3

Status

Thunderbird
General
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Ian Spence, Assigned: Ian Spence)

Tracking

({regression})

Trunk
Thunderbird 3
All
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

10 years ago
Since the landing of bug 406883, the header in the preferences window can result in invisible text, making it difficult for users to use. Attached is a screenshot showing the issue.

My comment from bug 406883 explaining the issue
--------------------
It should be noted that this "breaks" the preferences dialog in Thunderbird. It
currently has some CSS that tries to make these headers look native-ish for
Vista. These conflict, thus making things break (a lot of themes have the
listbox background color white, and the thunderbird css makes the text white...
so invisible text)

Now I'm not positive, but we might magically fix this with the landing of bug
412092, since the -moz-appearance would override most of that.  That being
said, I'm trying to figure out some perf issues with that bug (perf is fine
everywhere except the new url autocomplete, but I think I know a fix for that),
so it could be a week of unusable preference windows for Thunderbird users
--------------------

Comment 1

10 years ago
The screen shot is https://bugzilla.mozilla.org/attachment.cgi?id=299636
Keywords: regression

Comment 2

10 years ago
Created attachment 301480 [details] [diff] [review]
Patch rv. 1.0

Patch.

Adding winstripe's rules of |.paneSelector| (and |-moz-appearance: none;|) to |radiogroup.paneSelector| for GTK2.
Assignee: nobody → taken.spc
Status: NEW → ASSIGNED
Attachment #301480 - Flags: review?(bienvenu)

Comment 3

10 years ago
Created attachment 301496 [details]
Screenshot with patch

Comment 4

10 years ago
Comment on attachment 301496 [details]
Screenshot with patch

Oops, I forgot to attach the screenshot :-(.
Attachment #301496 - Attachment description: Scre → Screenshot with patch
Why keep the vista-ish look for Thunderbird on Linux?

Updated

10 years ago
Attachment #301480 - Flags: review?(bienvenu) → review+

Comment 6

10 years ago
(In reply to comment #5)
> Why keep the vista-ish look for Thunderbird on Linux?
> 

Because Qute theme is shared with Windows. Implementing Gtk2-ish look, we need more |ifdef|s or Qute-gnome.
So you are not going to ship individual themes (winstripe/pinstripe/gnomestripe) for thunderbird 3 like firefox 3 will?

Comment 8

10 years ago
(In reply to comment #7)
> So you are not going to ship individual themes
> (winstripe/pinstripe/gnomestripe) for thunderbird 3 like firefox 3 will?
> 

I don't know plans for thunderbird 3, but there are only two themes (pinstripe for OS X and qute for Windows/Linux) at this time and doesn't seem active development for themes.
# Implementing gtk-ish thunderbird theme should be filed as another bug if it was needed.
(Assignee)

Comment 9

10 years ago
Created attachment 302025 [details] [diff] [review]
Makes the header match Firefox's preferences

Just giving an alternative patch, not taking this bug.

This makes the header look like Firefox's
(Assignee)

Comment 10

10 years ago
Created attachment 302026 [details]
Screenshot with my patch applied

Comment 11

10 years ago
Ian's patch looks good.

In fact, I'm not sure what will happen Thunderbird's theme.
It might good idea to make Thunderbird's theme gnome-ish at this time.
# Previous my comments might be out of line.

I reset "assign to".
Assignee: taken.spc → nobody
Status: ASSIGNED → NEW

Comment 12

10 years ago
For native theming see bug 406742, bug 415415.

Ian: the patch looks good, I think we should go with it - the pref pane looks pretty broken now and I don't expect a gnome theme very soon, though sure would be nice for tb3. 
Assignee: nobody → ispence

Updated

10 years ago
Attachment #301480 - Attachment is obsolete: true

Updated

10 years ago
Attachment #301496 - Attachment is obsolete: true

Comment 13

10 years ago
Comment on attachment 302025 [details] [diff] [review]
Makes the header match Firefox's preferences

r=me, I'll check this in for you.
Attachment #302025 - Flags: review+

Comment 14

10 years ago
Checking in mail/themes/qute/mail/jar.mn;
/cvsroot/mozilla/mail/themes/qute/mail/jar.mn,v  <--  jar.mn
new revision: 1.22; previous revision: 1.21
done
Checking in mail/themes/qute/mail/preferences/preferences.css;
/cvsroot/mozilla/mail/themes/qute/mail/preferences/preferences.css,v  <--  preferences.css
new revision: 1.10; previous revision: 1.9
done

->FIXED
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3
You need to log in before you can comment on or make changes to this bug.