Zoom level jumps when going to gmail.com, unless i switch tabs

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: Michaël Arnauts, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows Vista
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3pre) Gecko/2008012704 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3pre) Gecko/2008012704 Minefield/3.0b3pre

There seems to be a problem with the site-specific settings. When i go to gmail.com (and i'm still logged in), the loading... is correctly zoomed, but when my inbox shows up, i can see the zoom going to 100%. When i open another tab, and go back to the gmail-tab. I can see it jump back to my zoom level.

could be related to bug #386835

Reproducible: Always

Steps to Reproduce:
1. go to www.gmail.com (make sure you are logged in, and you have gmail zoomed)
2. see the loading... correctly zoomed
3. see the inbox jump to 100% zoom
4. go to another tab
5. go back to the gmail-tab
6. see the inbox jump back to my set zoom level
(Reporter)

Comment 1

10 years ago
I still see this behavior with the latest nighty... Am I the only to notice this problem?

Comment 2

10 years ago
I see this behavior with 100% consistency.

It happens exactly the way Michaël describes it.

Are two confirmations enough to justify changing the status from UNCONFIRMED to NEW?

Comment 3

10 years ago
Confirmed as NEW. Another testcase is http://www.sport-fm.gr (non-english, uses iframes like the testcase in bug #422319.). That site automatically reloads every 30 sec. Then it resets to 100% zoom. Zoom reverts to correct state after going to another tab and returning.
The problem still exists in current nightly Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041807 Minefield/3.0pre
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

10 years ago
Duplicate of this bug: 422319

Updated

10 years ago
Version: unspecified → Trunk
(In reply to comment #3)
> Confirmed as NEW. Another testcase is http://www.sport-fm.gr (non-english, uses
> iframes like the testcase in bug #422319.). That site automatically reloads
> every 30 sec. Then it resets to 100% zoom. Zoom reverts to correct state after
> going to another tab and returning.

I see this too, although I don't see the problem anymore after reverting it to the correct state by going to another tab and returning.

Comment 6

10 years ago
Created attachment 322838 [details]
simplified testcase

Comment 7

10 years ago
Well... the testcase doesn't work here exactly as it does on my desktop. You need to correct it or download and run it locally. Anyway, it took me quite a few hours to extract a simplified testcase from the url I mentioned in comment #3 and its behaviour is somewhat different now: It increases the default zoom ! I shouldn't have simplified it so much! Nevertheless, I think that this testcase does its job because it shows how a reloading of the page (using location.href) can change its zoom. When I ran it locally, the page zoom changes, after 3 seconds, without user intervention.
Keywords: testcase

Updated

10 years ago
Attachment #322838 - Attachment is obsolete: true

Comment 8

10 years ago
Created attachment 323269 [details]
simplified testcase invoking location.href method

Hoping this works directly from the web. I'm not sure whether thuis testcase is entirely related to this bug but 1) It does affect page zoom 2) You don't need to do anything, just wait 3 secs and see the page zoom changing, 3) It uses location.href method as the sites already mentioned do.
Did the fix for bug 433727 make things better here?

Comment 10

10 years ago
Unfortunately not. Tested with trunk build 2008060306 Minefield/3.0pre on www.sport-fm.gr

Comment 11

8 years ago
WFM for a long time, I think (currently using Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101114 Firefox/4.0b8pre). Please reopen in case you still see this bug.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.