text/plain attachments are sent with "Multipart/mixed" and "Content-Disposition: inline"

RESOLVED DUPLICATE of bug 65794

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 65794
10 years ago
10 years ago

People

(Reporter: Pedro Freire, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; InfoPath.1; .NET CLR 2.0.50727)
Build Identifier: 2.0.0.9 [20071031]

Attaching files with extensions ".cs" or ".txt" makes them displayable in the recipient's body instead of being available for download as attachments.

RFC 1806 states "Content-Disposition: inline" is only for attachments that should be opened automatically for display, as opposed to "Content-Disposition: attachment" which would require user action. Thunderbird sends attachments with the former, when it should (IMHO) send with the latter.

This is related (bit not the same) as bugs 307706 and 385165.


Reproducible: Always

Steps to Reproduce:
1. Compose new message
2. Attach a "sample.txt" file
3. Send the message
4. Re-open the sent item in another client, or even in Thunderbird's "Sent Items"
Actual Results:  
Embedded (not "attached") content

Expected Results:  
Attached content
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 65794
You need to log in before you can comment on or make changes to this bug.