Compatibility fixed for add-ons should be applied automatically before startup

RESOLVED FIXED in mozilla1.9

Status

()

Toolkit
Add-ons Manager
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: Christiaan Hofman, Unassigned)

Tracking

unspecified
mozilla1.9
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b3pre) Gecko/2008012604 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b3pre) Gecko/2008012604 Minefield/3.0b3pre

When I install a new version of FireFox, the installer offers to download upgrades of add-ons. However sometimes upgrades of add-ons are not found, but old versions apparently can be upgraded to be compatible with the new version (this is what it says in the Add-Ons panel). However this compatibility upgrade is not performed automatically, I have to go to the Add-Ons panel, upgrade manually, and restart FireFox again. This should be done automatically at the same time as the automatic upgrade of add-ons.

Reproducible: Always

Steps to Reproduce:
1. Install a new version of Firefox/MineField
2. Start it up
3. If there are upgrades of add-ons, choose to download them and restart FireFox/MineField
Actual Results:  
Incompatible add-ons are disabled. If I go to the add-ons panel, some add-ons can be upgraded. For those to work I have to choose to do a compatibility upgrade and restart FireFox/Minefield.

Expected Results:  
Compatibility upgrades should be applied automatically, or at the least the initial dialog should offer this.
Where is this "Add-ons" panel? Why is this an installer bug?
(Reporter)

Comment 2

10 years ago
The add-ons panel is called through Tools > Add-ons. It's an installer bug because it happens when I install a new version of FF, or at least it should. 
That is a first run issue on upgrade of the application and not an installer bug
Component: Installer → Extension/Theme Manager
QA Contact: installer → extension.manager
Actually when you start a new version of firefox (new as in a different version number, not just a new nightly build) we do display a dialog about the add-ons that are incompatible with the new version and do a check for updated compatibility info for them and enable them if possible.
(Reporter)

Comment 5

10 years ago
First, for me as a user, I don't know if this step belongs to the installer stage or the startup stage, and I don't care. 

As for Dave's remark, that's partly correct (and the thing I'm talking about). However this does not apply any necessary compatibility upgrade (whatever a 'compatibility upgrade' is, I'm not talking about a download of a new version). 
(In reply to comment #5)
> As for Dave's remark, that's partly correct (and the thing I'm talking about).
> However this does not apply any necessary compatibility upgrade (whatever a
> 'compatibility upgrade' is, I'm not talking about a download of a new version). 

This is probably due to the same issue as bug 424107
I believe that this is now fixed, can anyone confirm?
Fixed by bug 424107 I think.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.