trace_malloc_leaks Linux fxdbug-linux-tbox Dep increase Lk:3.51MB --> Lk:3.73MB ~20080127 00:00

RESOLVED FIXED in mozilla1.9beta4

Status

()

P2
normal
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: stevee, Assigned: karlt)

Tracking

({memory-leak, regression})

Trunk
mozilla1.9beta4
x86
Linux
memory-leak, regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Updated

11 years ago
Flags: blocking1.9?

Comment 1

11 years ago
A small leak was expected according to bug 401988 Comment #20.  Also since only a leak increase on linux is noted, bug 401988 looks like the only linux specific bug in the list.  
Bug 401988 seems the most likely culprit in that range.  A jump of 235kb seems
larger than the issue discussed in bug 401988 comment 20.
OS: Windows XP → Linux
Created attachment 299828 [details]
data from the Tinderbox log (in case it's purged)
(Assignee)

Comment 4

11 years ago
I'm sure it is bug 401988.
We are now using some fonts that we weren't accessing before, and cairo adds them to its cache.  This is a shutdown leak.  The patch in Bug 413050 is needed to empty the cache.
Depends on: 413050
(Assignee)

Updated

11 years ago
Blocks: 401988

Comment 5

11 years ago
We should get this in to reduce noise on shutdown leaks for sure.
Assignee: nobody → mozbugz
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
(Assignee)

Comment 6

11 years ago
Fixed by bug 413050.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9beta4
You need to log in before you can comment on or make changes to this bug.