Closed Bug 414538 Opened 13 years ago Closed 13 years ago

Sender-name encoding includes quotes when name contains parenthesis ( )

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 254519

People

(Reporter: bugzilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; da; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: version 2.0.0.9 (20071031)

When the name entered in the Account Settings includes some foreign character, the name gets both quoted and encoded, instead of just encoded.

Reproducible: Always

Steps to Reproduce:
1. Enter a name with foreign or other non-standard characters in the "Name" for the identity of an account (POP3/IMAP etc).
2. Create a new mail
3. Send it - and the receiver will also see the ", instead of only the name.
Actual Results:  
From: =?ISO-8859-1?Q?=22Nikolaj_J=F8rgensen_=28Stingbat=29=22?=
 <stingbat@stingbat.dk>
- or, as UTF-8 encoded -
From: =?UTF-8?B?Ik5pa29sYWogSsO4cmdlbnNlbiAoU3RpbmdiYXQpIg==?=
 <stingbat@stingbat.dk>

Expected Results:  
From: =?ISO-8859-1?Q?Nikolaj_J=F8rgensen_=28Stingbat=29?=
 <stingbat@stingbat.dk>

Simply NOT adding the quotes, if encoding is necessary.
However, quotes should of course be added, when encoding is NOT necessary.

This issue does NOT happen for the receiver (To:), this part works perfectly (that is, encoded correctly and without quotes). So only "Sender"-part is related.
Tried adding an identity with non-ascii chars, To and From look the same, and no encoded quotes - tested on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2008020103 Lightning/0.6a1 Thunderbird/3.0a1pre ID:2008020103
Just did some more investigation.

Actually it seems not to be related to the non-ascii characters, but rather if adding a ( or ) (perhaps also others) - which then makes the quotes get added.
But weither or not it should be added, I'm not fully sure - but if it gets encoded, it probably don't "need" the quotes, or? Of course it depends on the RFC's, but...

Some other clients just "sees" these quotes, which looks a bit odd. Thunderbird however, trims sender/receiver-name out, before "displaying".

Minor problem of course, but would be nice if it looked alike on all clients (so weither or not it is a Thunderbird problem or if it's rather the other mail-clients which has the actual problem with not "removing" the quotes).
Version: unspecified → 2.0
Summary: Sender-name encoding includes quotes → Sender-name encoding includes quotes when name contains parenthesis ( )
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 254519
You need to log in before you can comment on or make changes to this bug.