Int chars in subject kills rest of subject

VERIFIED FIXED in M17

Status

P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: bugzilla, Assigned: nhottanscp)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
If you send a mail with fx the followin headers:
Subject: første møde

the subject is correct shown in the Subject column of the 3pane, but when the 
selecting the mail the only thing that is shown is:
Subject: f

It seems like the parser dies because of not encoded subject with danish chars.

Since it's possible to parse it ok in the Subject column so should it be in the 
mail view.
(Reporter)

Comment 1

19 years ago
Created attachment 9587 [details]
Subject is shown differently

Comment 2

19 years ago
reassigning to rhp since I'm not sure where we're losing the subject, cc mscott.
Assignee: putterman → rhp

Comment 3

19 years ago
reassigning to hyatt.  It looks like the change to bold is causing this.
Assignee: rhp → hyatt
Summary: Int chars in subject kills rest of subject → Text in columns not cropped after marking message as unread
(Reporter)

Comment 4

19 years ago
What is going on here...? Why did you change the subject...?
The last comment:
"reassigning to hyatt.  It looks like the change to bold is causing this."
must be to bug 41463!
Summary: Text in columns not cropped after marking message as unread → Int chars in subject kills rest of subject

Comment 5

19 years ago
sorry, there's a bug in the current build where when you start using bugzilla 
heavily, old values start showing up in new bugs.  See 41373.  Sorry about that.  
I've been trying to be careful to prevent it from happening when I see this.

this bug should go back to rhp with a cc to mscott.
Assignee: hyatt → rhp

Comment 6

19 years ago
This seems kind of bad. Should be easy once I find it...Nominating for beta2

- rhp
Status: NEW → ASSIGNED
Keywords: nsbeta2
Target Milestone: --- → M17

Comment 7

19 years ago
Hi Naoki,
I think I need your help on this one. I've debugged it down to the point where 
we are doing the following at line 194 of 
mozilla\mailnews\mime\emitters\src\nsMimeHtmlEmitter.cpp :

rv = 
mUnicodeConverter->DecodeMimePartIIStr(NS_ConvertASCIItoUCS2(headerInfo->value)
, charset, getter_Copies(unicodeHeaderValue));


the value of headerInfo->value is "første møde" and charset is UTF-8.

Well, when I do the conversion, I get "f" for unicodeHeaderValue and rc is not 
zero, but its not a failure either 5242892.

- rhp
Assignee: rhp → nhotta
Status: ASSIGNED → NEW
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
QA Contact: lchiang → momoi

Comment 8

19 years ago
Putting on [nsbeta2+] [will be minus on 6/15] radar.
Whiteboard: [nsbeta2+] [will be minus on 6/15]

Comment 9

19 years ago
Per msanz, very bad must fix bug.  Removing 6/15.
Whiteboard: [nsbeta2+] [will be minus on 6/15] → [nsbeta2+]
(Assignee)

Comment 10

19 years ago
I cannot reproduce this. I copy/paste "første møde" in subject and sent by 4.x 
and 6.0 (as ISO-8859-1). In both cases I see the subject correctly.

Comment 11

19 years ago
I am not able to reproduce it on my NT machine but Henrik used Win 2000.
(Reporter)

Comment 12

19 years ago
The reason way you cant reproduce the problem is that when sending a mail 
from netscape 4.x with the subject "første møde" it will MIME encode the subject 
because of the "ø". This was not the case when I recieved the mail.

I'll attach a mail you can send to yourself via fx sendmail.
(Reporter)

Comment 13

19 years ago
Created attachment 9767 [details]
mail with difficult subject...:)
(Assignee)

Comment 14

18 years ago
I can reproduce this now.
The charset parameter for DecodeMimePartIIStr() specifies a default charset 
which is taken from folder attribute. That is filed as a bug 41125.
Currently, "UTF-8" is used as a default for this default value but that should 
be "ISO-8859-1" instead. I will make the change and that should resolve the 
problem of this bug.

Comment 15

18 years ago
You can also use NoMime.zip test case I uploaded for  
Bug 41816. Display of Message envelope headers
gets cut off for all the 8-bit no-MIME-encoded headers
there. (There are about 9 charsets in the data there
and all exhibit this problem except ISO-2022-JP which is 
7-bit code.)

Comment 16

18 years ago
For some reason, I18n QAs were missing from CC line. 
(Assignee)

Comment 17

18 years ago
checked in yesterday
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 18

18 years ago
Verified with build 2000061220 on win2k
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.