Recommended header in get add-ons tab looks wrong in linux environment

RESOLVED FIXED in Firefox 3 beta5

Status

()

Firefox
Theme
--
trivial
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Jakub 'Livio' Rusinek, Assigned: Michael Ventnor)

Tracking

Trunk
Firefox 3 beta5
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9b3pre) Gecko/2008012904 Fedora/8 (Werewolf) Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9b3pre) Gecko/2008012904 Fedora/8 (Werewolf) Minefield/3.0b3pre

1. wrong icon for the tab
2. wrong addon icon in the search
3. wrong search icon
4. strange "recommended" headers look

Reproducible: Always

Actual Results:  
very wrong appearance

Expected Results:  
beautiful tangoish style
Blocks: 404024
Component: OS Integration → Extension/Theme Manager
QA Contact: os.integration → extension.manager
Version: unspecified → Trunk
(Reporter)

Comment 1

10 years ago
Created attachment 300051 [details]
screenshot
(Reporter)

Comment 2

10 years ago
Compare "get addons" search field to the browser's search field.
Depends on: 414617
The search bar bits may get taken care of in bug 414617

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
I filed bug 414342 some time ago which is about consistent spacing and margins of the addons, preferences and pageinfo dialogs. Perhaps this can be done in one patch?
(Reporter)

Comment 5

10 years ago
This bug isn't about spacing and margins but mostly about icons, but if you see other issues, they can be probably fixed here too ;) .

Updated

10 years ago
Duplicate of this bug: 416012
Blocks: 418868
The icon issues will all be taken care of by bug 418868.
(Reporter)

Comment 8

10 years ago
Ok.
Is there anything left in this bug not already covered by the other mentioned bugs? Otherwise I will just close this one out.
(Reporter)

Comment 10

10 years ago
Search box left.

1) wrong icons in there
2) no focus because of XBL binding
(Reporter)

Comment 11

10 years ago
And text headers...
(In reply to comment #10)
> Search box left.
> 
> 1) wrong icons in there
> 2) no focus because of XBL binding

That is bug 414617.

(In reply to comment #11)
> And text headers...

Morphing to that.
No longer depends on: 414617
Summary: "get addons" tab in addons manager doesn't intergrate with linux environment → Recommended header in get add-ons tab looks wrong in linux environment
(Reporter)

Comment 13

10 years ago
Ok. Changing some CSS wouldn't require lot of work.
(In reply to comment #13)
> Ok. Changing some CSS wouldn't require lot of work.

By all means I can review a patch if you submit one.
(Reporter)

Comment 15

10 years ago
I tried to find out what class it (the header) is with DOM Inspector, but when loading XUL of addons manager in DOM Inspector, there's no way to display it (the header).
In the dom inspector you can use the file menu to inspect an already open xul window like the add-ons manager where the header is already visible.
Ventron and I have a patch in bug 418868 that fixes the rest of this.
Assignee: nobody → ventnor.bugzilla
Component: Extension/Theme Manager → Theme
QA Contact: extension.manager → theme
I went ahead and committed the fix tonight for other reasons. This should look correct in tomorrow's nightly.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 beta5
You need to log in before you can comment on or make changes to this bug.