when autocomplete shown, "go" button doesn't work

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: kontakt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9b3pre) Gecko/2008012904 Fedora/8 (Werewolf) Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9b3pre) Gecko/2008012904 Fedora/8 (Werewolf) Minefield/3.0b3pre

when I'm typing some url in location bar, autocomplete opens slowly itself and when I try to click "go" (not press "Return"), autocomplete hides and I must click "go" another time.

Reproducible: Always

Steps to Reproduce:
1. type some url while autocomplete enabled
2. click "go"
Actual Results:  
clicking "go" works only at second time

Expected Results:  
everything ok
WFM with latest trunk on Windows XP. Can you reproduce this in safe-mode?
http://kb.mozillazine.org/Safe_Mode_(Firefox)

Comment 2

11 years ago
I can confirm this using safe mode on Linux.

This is actually a lot more spread that he has described. If the autocomplete dropdown is showing, nothing outside of the dropdown responds to its click.  The dropdown simply closes
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

11 years ago
@Ria: look what platform am I using and then ask questions...

@Ian: Hmmm... We could leave, as it behaves like native component, or make it works by hacks.

Comment 4

11 years ago
Jakub, you need to stop being rude to the other people using bugzilla. It is getting to the point where I'm going to stop addressing your bugs.

I don't know about the rest of the people who work on your bugs, but I know I'm not paid to do these patches.  I do it for the fun of programming.  When you are rude to people who are trying to help you, it takes away the fun.
(Reporter)

Comment 5

11 years ago
Hey, there's Linux, not Windows selected... If make a mistake also people are saying "next time read..." etc.

It's true, I have that behaviour because I'm a Linux and opensource fanatic. Don't afraid to say that...
(In reply to comment #3)
> @Ria: look what platform am I using and then ask questions...
> 
Normally all reported bugs are tested on multiple platforms. Its routine.
It should not be necessary to ask additional information; this should be included in comment 0. 
Please read https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
(Reporter)

Comment 7

11 years ago
I will never test anything on Windows, because I don't like that platform.
If anyone would like to test the things - is welcome...
This is expected behavior. Why should we change it? Do other linux autocomplete popups have this behavior?
(Reporter)

Comment 9

11 years ago
But it makes life harder.
btw, this is WFM on Ubuntu using Firefox 3.5, and using go Arrow (button has gone)
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.