Crash when doing a valid http authentication

VERIFIED FIXED in M16

Status

()

Core
Networking
P3
critical
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Stephen P. Morse, Assigned: shaver)

Tracking

({crash})

Trunk
x86
All
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
1. Go to a page requiring http authentication such as the one cited above
2. Fill in any username and password (valid or not, doesn't matter)
3. Click on OK

Get the following crash.

_free_dbg_lk(void * 0x034d2150, int 1) line 1033 + 60 bytes
_free_dbg(void * 0x034d2150, int 1) line 970 + 13 bytes
free(void * 0x034d2150) line 926 + 11 bytes
PR_Free(void * 0x034d2150) line 66 + 10 bytes
nsAllocatorImpl::Free(nsAllocatorImpl * const 0x00c64b50, void * 0x034d2150) 
line 94 + 10 bytes
nsAllocator::Free(void * 0x034d2150) line 161
nsBasicAuth::Authenticate(nsBasicAuth * const 0x02d53100, nsIURI * 0x02e66340, 
const char * 0x014dda20, const char * 0x02d53180, const unsigned short * 
0x034d2030, const unsigned short * 0x034d3cf0, nsIPrompt * 0x02e27be0, char * * 
0x0012f794) line 84 + 9 bytes
nsHTTPChannel::Authenticate(const char * 0x02d53180, int 0) line 1907 + 151 
bytes
nsHTTPChannel::ProcessAuthentication(int 401) line 2283 + 31 bytes
nsHTTPChannel::ProcessStatusCode() line 2105 + 12 bytes
nsHTTPChannel::FinishedResponseHeaders() line 1996 + 8 bytes
nsHTTPServerListener::FinishedResponseHeaders() line 1063 + 11 bytes
nsHTTPServerListener::OnDataAvailable(nsHTTPServerListener * const 0x03115090, 
nsIChannel * 0x02e35ce4, nsISupports * 0x02e624c0, nsIInputStream * 0x030b124c, 
unsigned int 0, unsigned int 0) line 405 + 8 bytes
nsOnDataAvailableEvent::HandleEvent(nsOnDataAvailableEvent * const 0x03122cd0) 
line 406 + 47 bytes
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x03122e70) line 97 + 12 bytes
PL_HandleEvent(PLEvent * 0x03122e70) line 575 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x010f4160) line 520 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x00bc05d2, unsigned int 49420, unsigned int 0, 
long 17776992) line 1032 + 9 bytes
USER32! 77e71268()
010f4
(Reporter)

Comment 1

18 years ago
Nominating for dogfood since this prevents visiting any sites that require http 
authentication.
Keywords: crash, dogfood

Comment 2

18 years ago
Probably related to bug 41404. cc shaver.
Agreed.  (And I have a fix for 41404 now.)


*** This bug has been marked as a duplicate of 41404 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

18 years ago
No, it's not a dup.  This crash occurs when clicking OK and 41404 talks about a 
crash when clicking cancel.  And the stack traces of the two crashes are 
different.  See bug 41466 for the cancel stack trace.

So keep them as two separate bugs and if the same code-change fixes both, so 
much the better.  But if we dup them and the code change for the cancel case 
doesn't fix this case, then we have lost a bug report.  And this one is 
definitely dogfood (I hope pdt agrees) whereas the cancel crash is not.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 5

18 years ago
Reassigning to shaver because of the similarity to bug 41404
Assignee: gagan → shaver
Status: REOPENED → NEW
Severity: normal → critical
Status: NEW → ASSIGNED
Target Milestone: --- → M16
Touche'.

I don't think the fix for 41404 will get this one right now, but I'll get a
patch together that fixes both.  (cvs.mozilla.org isn't playing nice right now,
for some reason.)

Comment 7

18 years ago
*** Bug 41517 has been marked as a duplicate of this bug. ***

Updated

18 years ago
OS: Windows NT → All
All better.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 9

18 years ago
verified:
winNT 2000070508
Linux 2000070420
Mac OS8.6 2000070511
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.